network cannot connect

I am facing an issue with my DietPi on RPi3: out of a sudden I have lost connection to the device - my router was not able to assign an IP address to it, as it was declined by the DietPi. So obvisiosly I am not able to SSH into the DietPi anymore. I have tried to connect a monitor and a keyboard, and the error messages I see are the following:

Failed to start dhcpd on all interfaces
Failed to start WPA supplicant
Failed to start Raise network interfaces

The worst thing is, that I cannot even login into DietPi locally - either I have forgotten my password or DietPi is declining it for some reason (via ssh I was using public key authentication).

I have also tried to edit /etc/network/interfaces through connecting the SDCard to a PC, but it did not help. I also connected the RPi to a different router, but could not get an IP address assigned.

Any ideas how to solve this?

this is getting worse and worse.

i have changed my root password on the sdcard via booting a different system. but the then DietPi started to bootloop after starting the nmbd service.
then I have tried to restore a previously perfectly working backup of my system to a new sd card, but the system hangs at random: crng init done during boot…

Sorry for the late reply. If you still have this issue and you can manage to boot the system, please do: G_AGI haveged
These “random: …” errors lately appear on some systems and are a sign for empty entropy pool. The above package solves that, hopefully as well in your case.

And if this indeed helps, please send a dietpi-bugreport and paste the ID here. I want to collect systems with this errors to find similarities. The issue is known to Debian but there is not much progress to fix that so far…

Check out:

Btw. sometimes the boot goes on after waiting a long while. At least worth to give it a try.