Neither Ethernet nor Wifi working

Creating a bug report/issue

Required Information

  • DietPi version | Core 8 Sub 13 Rv 2
  • Distro version | bullseye
  • Kernel version | Linux Dietpi 6.1.21-v8+ #1642 SMP PREEMPT aarch64
  • Architecture | arm64
  • SBC model | RPi4 Model B

Extra details

Internet completely stopped working.
Ethernet connection says available - on - disconnected. Same for wifi. Onboard wifi is on, but SSID scanning is not working, cause “no wifi adapter was detected on your device”. Ethernet is plugged in, I tried two different cables, but it fails to connect.

And it just randomly stopped working. It used to work before, with Ethernet. Wifi I almost never tried since years I own the raspberry I guess. The only thing I can’t think of is that it stopped working after updating Dietpi version, but I’m not sure about it, even though I cannot think of any other operation I did on the system.

I’m also fine with resetting if it’s a reasonable option.

In case I’m missing some details I’m sorry, I’ll gladly send them if needed :slight_smile:

Thanks in advance!

Hey SanCigo, other clients on your network can still reach the internet?
can you show the output of:

ip a
cat /etc/network/interfaces
cat /etc/resolv.conf

Do you see LED activity on the network adapter when you plug in a cable? Can you reboot your system and check the following (assuming the Ethernet is connected)

journalctl -u ifup@eth0.service

Hi and thanks for your time.
I was busy and couldn’t answer before.

Yes, all the other clients in my network can connect, both with LAN and WiFi.

From the list of commands you asked me to try, these are the outputs, in order:

  1. Temporary failure in name resolution
  2. Network is unreachable

# Ethernet
allow-hotplug eth0
iface eth0 inet dhcp
address (my local address)
netmask (
gateway (my gateway)

This is WiFi, sorry for the screenshots but I don’t have ssh so no way to copy paste and WiFi is not important (I would like to fix it but my main connection for the rasp is via Ethernet)

nameserver (my gateway)

Hi, thank you for your answer.
Yes, both green and orange LEDs turn on.

I forgot to mention, maybe it’s important, at the startup I get the message “A start job is running for ifup for eth0” (and wlan0 as well, they swap like every second).

This goes on for a while, slowing down the boot process, and after a while just loads the terminal as it should, with internet not working ofc.

This is my output from the command (sorry for the photo but I have no ssh to copy paste ;(

I just recalled now that I booted the raspberry again that whenever my autostart script starts, I get the message:
"chmod: changing permissions of ‘/var/lib/dietpi/dietpi-autostart/’: Operation not permitted

Doesn’t seem to affect the actual startup script, but still I take the chance to mention it.

Thanks in advance!

you are booting of an SD card?

Looks like you have data corruption on one of the important network tools, not allowing to bring up the network anymore.

Yes, I’m booting on SD card. It’s very likely it got corrupted, it happens quite often.

Do you suggest to change SD card or to use another drive to boot the raspberry?

Unfortunately, SD cards are not that reliable and designed for 24/7 operation. Especially cheap ones. If using the RPi4, you could think about booting from a USB-connected device or take a look at the RaspiKey as an eMMC flash device.

So also a normal USB stick is fine or you think it would have the same problems as the SD card?

I had some micro USB pen drives in past but after 2 years they got slower and slower on write operations. Therefore I switched to RaspiKey. But usually a USB stick should fine as well.