NanoPi4S does not work at all - September 2022 version

Hi @MichaIng @Joulinar @trendy

Just downloaded the September version of DietPi for NanoPi R4S

It doesn’t work at all.

Nothing shows on my network - I tried both WAN port and LAN port.

The “sys” LED keeps flashing.

I tried 3 different microSD cards - all have same problem.

Unfortunately I can’t access previous versions to try and troubleshoot.

Webarchive file doesn’t fully download

Previous versions did work but I wiped the microSD card unfortunately

Mine is 4GB version R4S.

Can you reproduce this issue ?

There is no “September version of DietPi for NanoPi R4S”. The image is from April this year.

Did you run into issues after the last update? It works fine here on my 4 GiB R4S.

With “keeps flashing” you mean it does not flash/blink but stays lid? If it is flashing, it is heartbeat mode which means it did boot successfully (not saying anything about network), but if if stays lid, boot failed at early stage, i.e. hardware, bootloader or kernel issue.

However, I wanted to update our image anyway, so let’s try to debug in case if the new one fails to boot as well.

1 Like

Noted. I went to the current download link:

https://dietpi.com/downloads/images/DietPi_NanoPiR4S-ARMv8-Bullseye.7z

I haven’t used DietPi on R4S for quite a while. Today I flashed brand new image.

Are you able to try flash a new microSD card on your R4S please ?

Yes “sys” is flashing in heartbeat mode.

What port do you use ? LAN or WAN?

I’ve tried both.

I did flash this exact image when I created it and it worked fine, and still does work fine. However, I currently run it on “edge” kernel Linux 5.19, so in theory it is possible that the “current” (stable) kernel Linux 5.15 has an issue since a recent update. But you did not enable AUTO_SETUP_AUTOMATED=1 in /boot/dietpi.txt so that an automated upgrade of the kernel could cause this, right?

Okay, then it booted up fine and it must hence be an issue with the network.

You need to use the WAN port indeed, since DietPi currently enables the eth0 interface, which is a bit odd indeed. I’m already thinking about a solution for multi Ethernet boards, to loop through and set “up” each detected Ethernet interface until one is found which has a cable attached (carrier signal). By default, all interfaces are down, in which case the OS cannot know whether a cable is detected or know, so that all look the same and the first eth0 is selected for setup. And that one on R4S is WAN.

It can be changed afterwards in /etc/network/interfaces, replacing eth0 with eth1, then shutdown, re-attach the cable to “LAN” and boot up again.

1 Like

Well I learnt something today.

On my ASUS RT-AC86U router, I wasn’t able to see DietPi at all on the main screen “Network Map”: see below.

I learnt today that you need to go to ‘System Logs’ screen and then “DHCP Leases”

So I learnt not to rely on this front / main screen

Under System Logs I see correct DietPi showing up with IP address I can login to

Btw it is working for my on LAN port of R4S ! DietPi shows this as eth0

image

image

1 Like

Hi, I’m new with this distrib and I would like to use it because it seems to fit my needs (tailscale/samba/easy management) but unfortunately I do have the same issue.
I cannot see any DHCP lease BTW.
I have a ISP box which is 192.168.1.1 and is used for gateway and dns.
I’ve tried to change settings in /boot/dietpi.txt to match this but I cannot connect to the nanopi r4s : sys led is blinking and that’s it.
Do you have any advice ?

Which Ethernet port did you use? It currently needs to be the “LAN” port, not the “WAN” port, since DietPi sets up eth0 interface. Enhanced setup to check for actual cable link state, and setup the first Ethernet port with a cable (both ends) connected, respectively carrier signal, is still on the ToDo.

1 Like

I used the WAN one but I’ve changed to the LAN one and it doesn’t even switch on the lights port.
With the WAN one there were lights port blinking…
I will check my config and paste it on that forum, if it is possible.

The status of the LED might not be correct.

Yes you’re right but I check on the network (namp / angryipscanner) with both settings and I cannot get any ip… :frowning:
I’ve played a little bit with other settings and I’ve seen that I had a firstboot.log if I set “do not wait for network to boot on first boot” (or something similar ) to see if it can boot.
I guess so, I have an issue with my network settings that the device doesn’t like. :roll_eyes:

I have just set another clean sd and started with LAN and it works !

Thanks. Now I can enjoy discover the new OS.

2 Likes