NanoPi NEO4 - experiences so far

Just a few observations about getting a system up and running while hoping that an official build will happen at some point in the future (since it is almost identical to the M4 and the T4 I shall remain quietly optimistic).

My goal is to use the NEO4 as a backup NAS that rsyncs from my primary NAS overnight, it may also pull double duty as a retropi machine at some point in the future.
It will be connected to a USB3 drive cage containing 5x3TB drives.

As there is no DietPi image I flashed my system with the only one I could find (Armbian).
I then applied the script. Which looked like it worked, until it came time to reboot as once I logged in I was greeted with the following message repeated over and over

-bash: [: missing ]


No commands worked. One very sad and borked system.

These are the steps I eventually used to get a DietPi system semi up and running, there are a few issues but I think that’s mostly because I’m on the DEV branch of DietPi

  1. Flash with the latest Armbian image for the NEO4.
  2. Make sure it is fully updated.
apt update && apt full-upgrade
  1. Apply the DEV prep system script.
wget -O
chmod +x

After a reboot looked like everything worked.
System idles at about 30C for me, pushing it got it up to 40C … pushing it until it hurt got it up to almost 70C (all cores maxed), a fan really is required (or in my case I’ve just positioned it so the exhaust fan on the drive cage blows over it.)

I managed to configure the USB3 drive cage as a raid5 array, no issues there.

Copying to the USB3 raid array through a samba share the copy maintained a steady 110-120MB/s transfer rate, I’m more than happy with that (During this large copy the NEO4 hit 38C, ambient temp is 27C). I can completely saturate the gigabit ethernet, very stable during a 60 minute bulk copy.

So far I’m really happy with it.

Just ran the DietPi benchmark, once again happy with the results though I think the RAM read speed is a little unlikely but that could be because this is a cobbled together system.

Custom filesystem is the USB3 raid array.

8.5 seconds, very nice. Fastest RK3399 score i’ve seen!

Need to get me hands on one of these boards :slight_smile:

Hopefully the nice people over at FriendlyElec see this post and send you one (for testing and quality control of course).

I love their hardware. I also have a NEO2 which is pulling double duty as a PiHole and VPN gateway, it’s stable as a rock and the VPN is nice and fast (I managed 70+ Mbps over a 3,500km link)

Nice…I’m running a Nextcloud on the Orange Pi PC [thru a USB to SATA adapter, write thruput is NOTHING to write home about at ALL!], and a TOR/VPN on a Orange Pi Zero…I think the 64bit NanoPi NEO will be awesome…

Great job on building a distro for that…make sure you make an image of stock build so if something goes wrong you can restore easily.

You can get the heatsink for $5.99…first thing I woulda got :wink:

Quick OpenVPN speed comparison between my NEO2 and NEO4
NEO2 OpenVPN.png
NEO4 OpenVPN.png

As you can see the NEO4 is a bit of a beast, easily besting the NEO2 (even though both have AES hardware acceleration)

So far this little board has been an absolute pleasure to use, the only niggle I’m having with it is that occasionally (about once or twice per week at random) its SMB file shares drop out for about a minute, the shares always come back without needing to reboot but any file copy (on or off) ends up hanging.

Not sure if it’s because I’m using an unstable Armbian build as the base or if there is some underlying issue with the USB3 port (I’m confident I can rule out power issues as I’m using the official FriendlyElec power supply for the NEO4 and the USB drive cage has its own power supply.)

Just for reference I link the GitHub request for this image here:
I also added it to our new FeatHub page, so one can vote for it:

Here’s the latest benchmark after I rebuilt using the latest Armbian source … performance is much improved

For some reason using an M4 image (also built from source) is a shade faster on the NEO4.
Raid performance is still more than acceptable

NEO4 M4 Raid Nov 2019.png