Nanopi Neo odd poweroff

Hi there. The question is “pure academic” as the device is designed to work constantly, but nevertheless - it must be able to be powered down correctly.
As of now I’ve installed current (4.10.0) version and am running it for 2 hours already. :slight_smile: When I issue ‘poweroff’, the standard halt script is executed, the power led blinks several times, and then… the H3 starts to heat!!! Both Ethernet leds are lit, the Power led is off, and the CPU can instantly broil my finger. I had no patience to wait when it explodes and unplugged the power, but that’s not proper behavior in any way.
Can it be a hardware problem?..

Hm, perhaps I’m too fast in my expectations. The USB port is not working too. Must smoke manuals for a while…


Not in this case :slight_smile:
USB is broken on 4.10 kernel. We’ve replaced and reverted our DietPi image with a 3.x kernel (Stable), please re-download and re-write the image:

Ow. Hm, thank you, I’m exploiting armbian 5.25 for several days already, kernel 3.4.113; the cpu is cold as a frog most of the time. Is the power mgmt of Diet functional now?

Works for me on latest v145 image which contains the 3.x kernel.

Worked too, thanks. Now familiarizing with your image instead of volumio - man, I can’t solder 4GB into a nanopi.

OK, new issues. Signalyst networkaudiod binds ONLY to IPv6, and I cannot disable it at all. Tried to play with /proc/sys/net/ipv6/conf/all - no luck, it says disable_ipv6=1, but this cheeky thing finds some way to bind to :::43210.
Think I need to redo the kernel to axe it off completely (and free some ram btw).

Do you have the source tree available? I have linaro gcc 6.2.1 installed, on a vm of your x86 version. Thank you.


Unfortunately, networkaudiod is not open source software. No source code available.

Strange, my network is IPv4 only (personal preference :slight_smile:), networkaudiod binds to IPv4 fine.

dietpi-config > Network Options: Adapters > IPv6 > Disable

That was first that I tried. Not working.
Got the latest legacy from armbian, disabled ipv6 at all (did anybody ever use it?!) - now the daemon has no choice. Works.
Btw, the source code is available, but i doubt it’s GPL.