NanoPi Neo Air WiFi Not Working


I am new to the NanoPi and to DietPi, although I have experience with Raspberry Pis, OrangePiZero, and Odroid C0.

I just received a NanoPi Neo Air. My problem is that I am unable to locate the wifi module in DietPi (or in the Armbian Distributions as well, both legacy and nightly builds). I have tried (NR_4.x)_DietPi_v147_NanoPiNEOAir-armv7-(Jessie).img and DietPi_v145_NanoPiNEOAir-armv7-(Jessie).img. There is no wlan0 to be found under iwconfig. When I try

ifup wlan0

its says it can’t locate the device. When dietpi-conf starts it says that a wifi device is not found and when I tried to change the WiFi settings it said

No supported Wifi Hardware was found.

I even attached a WiFi dongle to a female USB port using the USB/I2S/IR Pin pins, and it was unable to find the device.

What is strange is that the internal WiFi module and an external WiFi module works fine with the Friendly Arm distribution nanopi-air-eflasher-sd8g-20170220.img.

Any ideas what is going on?


Hi Rod,

DietPi disables all known WiFi modules by default. This is to reduce memory usage.

To enable the WiFi adpater, either:

  • use dietpi-config > Networking to setup the adapter
  • Enable the WiFi modules and then setup manually:
/DietPi/dietpi/func/dietpi-set_hardware wifi onboard_enable
/DietPi/dietpi/func/dietpi-set_hardware wifi enable

Thanks for the reply. However, I tried both diet-pi config and the manual commands, and still I am told that Wifi is not found and that no supported wifi module is available. Iwconfig shows no wlan module.

Has Friendly Arm changed the hardware? WiFi works with their own distribution.

Hi Rod,

Possibly, or a faulty board, does WiFi work on other images?

What is strange is that the internal WiFi module and an external WiFi module works fine with the Friendly Arm distribution nanopi-air-eflasher-sd8g-20170220.img.

Interesting, must be a change to hardware.

Is there a revision code printed on PCB?

I’ve check both our AiR images, all appear to be working in regards to WiFi:

 DietPi     | 13:53 | Thu 30/03/17
 V147       | NanoPi NEO Air (armv7l)
 IP Address |
DietPi-Software is already running. Please complete the setup before continuing.
root@DietPi:~# iwconfig
lo        no wireless extensions.

wlan0     IEEE 802.11  ESSID:"FuzonWifi"
          Mode:Managed  Frequency:2.447 GHz  Access Point: E8:DE:27:4A:D0:66
          Bit Rate=52 Mb/s   Tx-Power=31 dBm
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:
          Power Management:off
          Link Quality=50/70  Signal level=-60 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth0      no wireless extensions.

Is there a revision code printed on PCB?

The WiFi module says this:

The wifi module is labeled as follows:


I think the board is V2, if the version number is located above “NanoPi Neo Air” under the eMMC.

Thanks for looking into this.


Hi Rod,

I also have the V/U2 under EMMC, not sure if it is rev code.

Appears chip is different, on mine:


Unfortunately, as the WiFi module is not found (lack of driver support for A model) and I lack this updated board for testing, we’ll need to wait for the ARMbian guys to pick up this change and implement support for it in their build tools. Once done, I can regenerate the image.

O.K. I fully understand. Thanks again for looking into it!


I wonder if this is the same problem getting the wifi going on Nanopi Neo (not air). See the thread.

Ifconfig would not find wlan0 even though lsusb showed the device was attached.

Seems like dietpi leaves out some of the drivers for wifi.

I did

Try installing full ARMbian firmware package:

Code: Select all
apt-get install armbian-firmware-full

That brought in about 1K of extra things that got my dongle up and working.