NanoPi NEO 2 v150 to v151 update fail

Hey, Still kinda new to this so any help would be appreciated.

Have tried multiple times updating from v150 to v151 and each time is unsuccessful.

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0curl: (6) Could not resolve host:
 [Failed] Download failed, unable to run update. Please try running dietpi-update again.

That is the error i keep getting each time. Any advice?

Looks like a DNS issue with your network.

Can you ping any of the following from system?

ping -c 1
ping -c 1
ping -c 1

I’m able to ping all 3 until i run ‘dietpi-update’, once that command is run i’m unable to ping any of them.

Are you running pi-hole on this box? I find I have the same issue on my Neo1 which is running pihole, have to revert to using DNS from my router to get it to update.

Yes I am, it seems as though it’s stopping all the processes before it tries to download anything.

update switched from static ip to dhcp and uninstalled pihole, update worked no problems.

Ahh, neat! I’ve got a big backup job running right now, which I don’t want to risk, but when it’s done I’ll be giving that a go.

It seems it’s the ‘uninstall pi-hole’ bit that makes this work not the change from static to DHCP (all my other devices update fine even though they’re set to static).

Looks like I’m still on the rigmarole of resetting DNS to the router, updating the pihole box and then setting DNS back to the pihole. :frowning:

this is failing on my pi. I uninstalled PiHole but i’m still getting the issues.