NanoPi M3 image


I decided to change the old v160 image on my M3 and restart with the new image (with the new version number). I download the image and burned it with Etcher… sorry Balena Etcher now. So I boot up the board, the lights flash… and nothing. I have a monitor connected to the board and I see no activity, the board want to deliver something because my monitor want to show me something (if the source is down, it automatically switch to the other source).

So I tried with another SD card, just in case, same scenario. I re-download the image… do the same process. Same result.

I tested with another sd card burner… same result. I then try to use an ols 143 (or so) image on my download folder (yes, I have to clean a bit) and after burning the image with Balena Etcher, it boot properly and start to update to v160.

So now I’m here to ask if there is a bug in the NanoPi M3 image.


Does anyone was able to reproduce this behavior?


Many thanks for your report. I moved to issue to GitHub for trying to replicate:
Sadly I have no M3 here so cannot test myself right now.

Thanks for the report. Let me know if I can do some tests for you! I’ll be happy to help.

New Buster-based images are available btw.