NanoPC-T4 NVME not found

I’m running from eMMC, with latest dietpi (kernel 4.4.154, v6.19.7), and have a new EVO 860 NVME drive mounted, but I see nothing listed in /dev:

block            loop2               ptmx    tty22  tty49    usbmon0
btrfs-control    loop3               pts     tty23  tty5     usbmon1
bus              loop4               ram0    tty24  tty50    usbmon2
char             loop5               random  tty25  tty51    usbmon3
console          loop6               rfkill  tty26  tty52    usbmon4
cpu_dma_latency  loop7               rkvdec  tty27  tty53    usbmon5
disk             loop-control        rtc     tty28  tty54    usbmon6
dri              mali0               rtc0    tty29  tty55    vcs
fb0              mapper              shm     tty3   tty56    vcs1
fd               mem                 snd     tty30  tty57    vcs2
full             memory_bandwidth    stderr  tty31  tty58    vcs3
fuse             mmcblk0             stdin   tty32  tty59    vcs4
hdmi_hdcp1x      mmcblk0p1           stdout  tty33  tty6     vcs5
hugepages        mmcblk1             tty     tty34  tty60    vcs6
hwrng            mmcblk1boot0        tty0    tty35  tty61    vcsa
i2c-0            mmcblk1boot1        tty1    tty36  tty62    vcsa1
i2c-1            mmcblk1p1           tty10   tty37  tty63    vcsa2
i2c-2            mmcblk1p2           tty11   tty38  tty7     vcsa3
i2c-4            mmcblk1p3           tty12   tty39  tty8     vcsa4
i2c-7            mmcblk1p4           tty13   tty4   tty9     vcsa5
i2c-9            mmcblk1p5           tty14   tty40  ttyFIQ0  vcsa6
iio:device0      mmcblk1p6           tty15   tty41  ttyS0    vendor_storage
initctl          mmcblk1rpmb         tty16   tty42  ttyS1    vhci
input            mqueue              tty17   tty43  ttyS2    vhost-net
kmsg             net                 tty18   tty44  ttyS3    vpu_service
kvm              network_latency     tty19   tty45  ttyS4    watchdog
log              network_throughput  tty2    tty46  uhid     zero
loop0            null                tty20   tty47  uinput   zram0
loop1            port                tty21   tty48  urandom

Is the issue that I’m running from eMMC, and should be using SD Card?

Sorry for the late reply. Did you manage to fix it?

Your kernel does natively support NVMe, so this cannot be the issue. SATA mode needs to be AHCI (as some desktop users report), but I guess this is default here, where er have no multiple SATA ports for RAID :wink:.

Please have a look into: dmesg

  • Watch out power voltage/power issues and NVMe related ones.
  • Perhaps you can even trigger new related errors when detaching and reattaching the drive.

I have not had luck as of yet. I’ve tried doing:

dd if=/dev/zero of=/dev/nvme0n1 bs=4K count=10000

but I don’t see the standard 5 or 6 nvme devices under /dev/

I can see I’m configured to support it as far as I can tell:

zcat /proc/config.gz | grep NVME

I tried to scan using smartctl, but no luck. No luck with nvme (nvme-cli package) either. Wondering if it’s something to do with my physical setup. I had a SD card (also a Samsung EVO) so I removed that just to make sure it wasn’t causing an issue. I have a raid setup behind USB 3.0, maybe that’s an issue?

I guess I could try installing it while the device is on, but that seems unwise and unnecessary. I’m sort of at a loss at this point.

As long as the device does not show up in /dev/nvme*, there is no point in doing dd if=/dev/zero of=/dev/nvme0n1 bs=4K count=10000 of course.

Jep the /proc/config.gz verifies that NVMe support is by default present on “modern” kernel (>= 3.1, so since long time already).

Drive_manager, nvme-cli packages and other software all are frontends and require the device to show up under /dev, so as long as this is not the case, there is no point in further checking different things.

As said, please check: dmesg for hardware/firmware/power related kernel messages
Hmm, indeed the RAID setup “might” be related. I have not much experience with this, but quick web search lead to SATA mode needs to be AHCI and on desktop machines you can usually switch between AHCI and RAID. Not sure how this is handled on SBCs without a BIOS/UEFI setting possibility, or is there something implemented into the NanoPC-T4?

If the above gives no result, you could simply try to detach the RAID drives and see if perhaps internally SATA drive mode is switched automatically, allowing to detect the NVMe drive. Would be indeed a sad thing, if RAID + NVMe would be not possible :thinking:.