I tried to install myMPD, however part of the setup instructions says go to 192.168…:1333. Problem IS my local network uses 10.10… and not the standard 192.168… myMPD is not like LMS were it just adopts the current IP of the machine its on and uses the same port.

Besides switching my whole local network back to 192.168… would there be any other way to connect to the web GUI?

Also BTW, trying to Uninstall myMPD along with MPD via the Dietpi GUI does not work…I had to manually uninstall and purge then do a autoremove.

Use the IP address of your Pi machine…if it is DHCP you might have to use your router to figure out what the IP address is, if it’s static then use the 10.10..:1333 one

Hi WarHawk

I tried my local machine IP, nothing.

I updated the mympd.conf file to

#myMPD config file

#Connection to mpd
mpdhost =<----local IP
mpdport = 6600
#mpdpass =

#Webserver options
webport = 1333

#Enable ssl
ssl = true<-----True per directions
sslport = 443
sslcert = /etc/mympd/ssl/server.pem
sslkey = /etc/mympd/ssl/server.key

#myMPD user
user = mympd

#Port for mpd http stream
streamport = 8000

#Name for coverimages
coverimage = folder.jpg

#myMPD statefile
statefile = /var/lib/mympd/mympd.state

#Enable mixramp settings
mixramp = false

#Enable usage of mpd stickers for play statistics and voting
stickers = true
group = dietpi

I enter in my browser and nothing  :thinking:

btw, I can connect to MPD with an external client just fine, the database updated etc. etc.

I wonder if something is blocking the port??


Nope all I get is connection refused.

I see here that this was actually a bug and was fixed in version 4.1.2 a couple of days ago.

Is there anyway I can find out which version I have and/or update it to the latest version?

Unknown on seeing what version

Have you installed all dependencies?

libmpdclient 2: <------This does install via the Dietpi installer 100% sure
OpenSSL: <-------Not sure if this installed, I did see the below files so I assume it did…

Saw these files so I assume openssl installed via the dietpi installer too.
sslcert = /etc/mympd/ssl/server.pem
sslkey = /etc/mympd/ssl/server.key

I tried everything I could think of, made sure ports were open and forwarded in the router, changed ports, etc. etc.
Only thing I can think of is the bug in the old version that was talked about in the github post.

Shrugging shoulders…
I might try a manual install just for kicks, see what happens.

Anything in the logs…are there any even logs?

No log file…

I think we jumped the gun including myMPD, looks like it needs more testing.

I tried it on all of my boards and the results are the same.

ASUS Tinkerboard
Odroid C2
All versions of Raspberry Pi

Looks simple enough, should be simple enough…but its not.

Maybe a DEV guy can jump in…I’m at a loss

myMPD instructions give this information concerning SSL

1.Create ca and certificate /usr/share/mympd/ ( does this for you).
2.Set ssl=true in /etc/mympd/mympd.conf (use default certificate under /etc/mympd/ssl/).
3.Import /etc/mympd/ssl/ca/ca.pem in your browser to trust the certificate.
4.myMPD redirects http requests to https, ensure that myMPD hostname is resolvable

It appears that #3 requires me to 'IMPORT' the ssl certificate into my browser....however gives no instructions on just how to do that.

Any ideas??

Thanks for the link WarHawk, nope doesn’t look like thats it either…I am familiar with that process, but I don’t get that option or page.

FWIW I do ‘think’ it sees the mympd web server ‘but’ access is always denied.

I also noticed that one of the RUN files outlines on the myMPD github page is not in Dietpi

Run Flags
Usage: ./mympd /etc/mypd/mympd.conf

Looks like it needs the two of them, I do see the mympd.conf but not the ./mympd

Thanks for all your help, but I also think the Dev needs to take a look at this…


Good News!

Its not just Dietpi…

I installed myMPD manually unto a fresh install. Dependencies etc all installed and still the same issue.

I was able to connect to MPD with an external client with no problem but myMPD had the same issue. I opened up a ticket at the mympd github but they quickly closed it…I know 90% of the time support thinks it DFUE.

No worries, I gave it good effort to try and make it work…it didn’t, no forum for myMPD, no support so I am moving on… :open_mouth:

However, if I were Dietpi dev I would consider removing it from the software list. myMPD does not live up to the ease of use and robustness that ‘should be’ and IS to a lot of people as Dietpi’s trademark and brand image. Not only mympd but any software that is not robust and easy to use reflects bad on Dietpi as users rightfully or wrongfully blame Dietpi…seeing that its in ‘your’ bundle.

Just a thought. :slight_smile:

Thanks Edward,

Yep, i’ll open a ticket to review this software title, and, verify non-DietPi issue:


Appears to be a bug our end, apologies. Fix is due for v6.17, solution can be applied now to also resolve, please see below:

Okay Great!!!

I’ll give it a go and see how it turns out.

Wow I was beating my head on the walls for days about this… :stuck_out_tongue:

So let me ask you…can I actually put the MPD computer IP and port in the mympd.conf file and use 1333 as the mympd port?

And did you actually see the mympd GUI with your own two eyes in a browser? :smiley: :thinking:



:smiley: :sunglasses: :rofl:

Not quite ready.

Now we have ownership issues.

Dietpi owns the samba drive
MPD is the user for MPD therefore I can’t connect to the music unless I change user to dietpi or root
But if I change the MPD user to dietpi or root, mympd doesn’t connect to MPD

Hello everybody!

I ran into the same problem, reread the thread, tried the suggested solutions, but nothing helped. ssl is still not working. Version DietPi v6.19.7
The usual connection to mympd works, but it does not see the music base, but only the directory tree. If I enable

ssl = true

, then the browser cannot connect to mympd at all.

Help me please.

Sorry for bad english, i use google translator.

Special thanks to the developers of DietPi for a wonderful product!

Hello from Russia! :slight_smile: