Mullvad Vpn gui doesn’t start

i have the latest dietpi on my pc and I tried to install mullvad vpn gui I think it worked I see the Icon mullvad vpn but if I click on it nothing happens any idea? I’m a Linux noob if you need any information please tell me how I can do it with terminal step by step

root@DietPi:~# sudo apt install -y ./MullvadVPN-2022.2_amd64.deb
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Note, selecting 'mullvad-vpn' instead of './MullvadVPN-2022.2_amd64.deb'
The following package was automatically installed and is no longer required:
linux-image-5.10.0-15-amd64
Use 'sudo apt autoremove' to remove it.
Recommended packages:
libappindicator3-1
The following NEW packages will be installed:
mullvad-vpn
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/72.4 MB of archives.
After this operation, 278 MB of additional disk space will be used.
Get:1 /root/MullvadVPN-2022.2_amd64.deb mullvad-vpn amd64 2022.2 [72.4 MB]
debconf: delaying package configuration, since apt-utils is not installed
Selecting previously unselected package mullvad-vpn.
(Reading database ... 61651 files and directories currently installed.)
Preparing to unpack .../MullvadVPN-2022.2_amd64.deb ...
Unpacking mullvad-vpn (2022.2) ...
Setting up mullvad-vpn (2022.2) ...
Created symlink /etc/systemd/system/multi-user.target.wants/mullvad-daemon.servi <[http://multi-user.target.wants/mullvad-daemon.servi>](http://multi-user.target.wants/mullvad-daemon.servi%3E);
ce → /opt/Mullvad VPN/resources/mullvad-daemon.service.
Created symlink /etc/systemd/system/mullvad-daemon.service → /opt/Mullvad VPN/re
sources/mullvad-daemon.service.
Processing triggers for hicolor-icon-theme (0.17-2) ...
N: Download is performed unsandboxed as root as file '/root/MullvadVPN-2022.2_amd64.deb' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)

looks like you have some permission issues on the file /root/MullvadVPN-2022.2_amd64.deb you try to implement. Can you check what permissions are set? Maybe better to move this file to /tmp instead of root user directory /root/

If you tell me how, where and what I need to type i will do it.

Do you need this?

mv /root/MullvadVPN-2022.2_amd64.deb /tmp/
apt install /tmp/MullvadVPN-2022.2_amd64.deb

Thank you now I get this output but mullvad gui still doesn’t load I see the icon under start/internet/mullvad vpn after clicking nothing happens hmmm but it worked one time 6-8 months ago I used it then I change my vpn provider now I want go back to mullvad and I need the gui

root@DietPi:~# mv /root/MullvadVPN-2022.2_amd64.deb /tmp/
root@DietPi:~# apt install /tmp/MullvadVPN-2022.2_amd64.deb
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Note, selecting 'mullvad-vpn' instead of '/tmp/MullvadVPN-2022.2_amd64.deb'
The following package was automatically installed and is no longer required:
  linux-image-5.10.0-15-amd64
Use 'apt autoremove' to remove it.
Recommended packages:
  libappindicator3-1
The following NEW packages will be installed:
  mullvad-vpn
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/72.4 MB of archives.
After this operation, 278 MB of additional disk space will be used.
Get:1 /tmp/MullvadVPN-2022.2_amd64.deb mullvad-vpn amd64 2022.2 [72.4 MB]
debconf: delaying package configuration, since apt-utils is not installed
Selecting previously unselected package mullvad-vpn.
(Reading database ... 61651 files and directories currently installed.)
Preparing to unpack .../MullvadVPN-2022.2_amd64.deb ...
Unpacking mullvad-vpn (2022.2) ...
Setting up mullvad-vpn (2022.2) ...
Created symlink /etc/systemd/system/multi-user.target.wants/mullvad-daemon.servi
ce → /opt/Mullvad VPN/resources/mullvad-daemon.service.
Created symlink /etc/systemd/system/mullvad-daemon.service → /opt/Mullvad VPN/re
sources/mullvad-daemon.service.
Processing triggers for hicolor-icon-theme (0.17-2) ...

Did you tried to restart the system? Or using our dietpi-vpn script if you have the configuration file available.

I did a restart but still doesn’t start. Yes I know dietpi-vpn but I want use the gui

And mullvad can’t help they say this

We have not tried that platform and are not supporting different Debian / Ubuntu flavors as we have no idea what services they have removed or not.

As per your output you’re having permission issues reading the file.
Try changing the permission so that all users can read/execute the file.

Or try using gdebi to install the file.

basically the package has been installed successfully and a service has been created. What is the status of these service

systemctl status mullvad-daemon

● mullvad-daemon.service - Mullvad VPN daemon
     Loaded: loaded (/opt/Mullvad VPN/resources/mullvad-daemon.service; enabled;
 vendor preset: enabled)
     Active: active (running) since Thu 2022-07-21 17:57:48 CEST; 3h 
52min ago
   Main PID: 793 (mullvad-daemon)
      Tasks: 13 (limit: 9305)
     Memory: 26.8M
        CPU: 238ms
     CGroup: /system.slice/mullvad-daemon.service
             └─793 /opt/Mullvad VPN/resources/mullvad-daemon -v --disable-stdout
-timestamps

Jul 21 17:57:48 DietPi mullvad-daemon[793]: [mullvad_daemon::account_history][INFO] Opening account history file in /etc/mullvad-vpn/account-history.json
Jul 21 17:57:48 DietPi mullvad-daemon[793]: [mullvad_daemon::target_state][DEBUG] No cached target state to load
Jul 21 17:57:48 DietPi mullvad-daemon[793]: [talpid_core::firewall][INFO] Resetting firewall policy
Jul 21 17:57:48 DietPi mullvad-daemon[793]: [talpid_core::firewall::imp][DEBUG] Removing table and chain from netfilter
Jul 21 17:57:48 DietPi mullvad-daemon[793]: [mullvad_daemon::version_check][DEBUG] Loading version check cache from /var/cache/mullvad-vpn/version-info.json
Jul 21 17:57:48 DietPi mullvad-daemon[793]: [mullvad_daemon::version_check][WARN
--More--

at least the service is running. But honestly I’m not sure why the gui is not loading.

I found something but I’m not sure if it helps I think same problem but different os

https://github.com/mullvad/mullvadvpn-app/issues/2992

at least you could try this

I edited /opt/Mullvad VPN/mullvad-vpn to run the gui with the --no-sandbox flag, now it works.

Not working :frowning: i hope someone have another idea