MPD, MPDroid & O!MPD Help

Hi,

I’m having a few issues with MPD and wondered if I could get some help?

I’m aware of the following post which helped me part of the way:

https://dietpi.com/forum/t/solved-mpd-mympd-mpdroid/2612/1

I’m trying to play music on my Android phone with MPDroid or a similar application.

I changed the bind to address to that of my Pi which let me connect via MPD:

bind_to_address "192.168.1.167"

I also added the following lines to allow me to play streams via web browser of via the MPDroid App (It also works well via VLC)

audio_output {
type "httpd"
name "My HTTPD Stream"
port "9500"
}

My issues are as follows:

How do I get MPDroid to show album art? Iv’e tried all the settings and can’t get anywhere.

I’m also using O!MPD (Which has a great UI). It only seems to play direct through the Pi. How do I configure it use the HTTPD stream that I set-up in the MPD Configuration?

Many thanks

Peter

PS - I’m using a Raspberry Pi 3, with the latest version of DietPi.

If O!MPD or other clients show album art successfully then it is not related to the server setup but at MPDroid to pull album arts or not. I would ask their devs then about how to achieve that or if this feature is even available yet.

AFAIK this is a strict server < client system. So MPD just offers port 9500 (in your case) to pull the audio steam from, but it cannot (thus O!MPD cannot) force any client connected via this port to play music. But perhaps it works when you add always_on yes to the audio_output, then connect once with MPDroid. Possibly since the connection stays active/opened with this, it is used then as output automatically. Perhaps you need to disable the ALSA output first as well.

Source: https://www.musicpd.org/doc/html/user.html#configuring-audio-outputs