Mount nfs shares from fstab

This fstab line works fine in Odroid XU4 but stops BananaPi from booting - both on v 156 DietPi and both on wired LAN. /mnt/completed nfs rsize=8192,wsize=8192,timeo=14,intr,nofail 0 0

I assume it is due to the networking not being up as I can mount the share from the command line.

I have spent hours on this today to no avail - I have tried the _netdev option in fstab. I tried autofs. No luck with either.

Any ideas?

Hi johnvick I had the same trouble, it was simply not mounting, the share, looking into log I found something like rpcbind was not yet started.
I used as workaround to put last line in /etc/rc.local the command to mount the share , before the last line “exit 0”.
This worked for me, I wasted a day on it but no way to let it start at boot time by fstab only.

Thanks but no luck with this here - I put a sleep 20 before the mount command but again no difference.

I tried crontab -e

and added

@reboot mount -t nfs /mnt/completed

to the end of the file, but no luck with this either!


Editing the line in fstab to: /mnt/completed nfs rsize=8192,wsize=8192,timeo=14,intr,nofail,noauto,x-systemd.automount 0 0

noauto,x-systemd.automount - this was the key.

Sorry for arriving late… I had the same problem before and had solved it by adding noauto,x-systemd.automount to the fstab line.
I think I’ve written about this somewhere on the board, but can’t find where. :slight_smile: