mount error(115): Operation now in progress

Running DietPi 158 on rpi3. When I attempt to update, I get a mount error. I get the same error when trying to enter the DietPi Drive manager.

Last night I successfully had mounted a USB drive, but hadn’t really been using it for anything yet. This morning, I unplugged that drive and inserted another USB thumb drive that I wanted to use instead. When trying to enter Drive Manager to refresh my mounts, I started seeing this error. I’ve rebooted the Pi to no avail.

If I let this error sit for a few minutes, it eventually continues but does not see any external drive. I’m wondering if the initial unplug of the first USB drive, without doing a proper umount (I’ve been out of the Linux game for many years), hosed one of my file services. Although I would suspect a reboot to fix that, but maybe not.

Any thoughts are appreciated.

Thank you for the great software, excited to get my new Subsonic server up and running.

EDIT: Just a quick update before I hit the Submit button. I ran the dietpi-update from 158 to 159. It hung for a few minutes at the mount error(115) message but let me continue. After reboot, I entered Drive Manager and it saw my /dev/sda1 USB drive, although I still see the mount error(115). Just wanted to give a little more info, as I haven’t seen another case like this one in the forums, so hopefully if anyone else has this problem, they can look here.

Try commenting out any references to the USB drives in /etc/fstab and rebooting.

Then try the update.


Thanks for the tip. You prompted me to check out fstab in which I saw that I had CIFS configured to a Windows share that changed IPs. So I removed that and no more error. Thank you for pointing me in the right direction, I’m an idiot.


Awesome! Good job

This is why it’s preferable to use machine names instead of IP addresses, as these might change.