MotionEye - Unable to Open Video Device after Resolution Change

Hello folks,

Not sure if this is the best place to post this, but I hope you can help with this strange issue.

Hardware : Pi Zero W with a wide angle IR camera with 2 IR lights bolted to the side
Software : DietPi, then MotionEye using their automated process.

Issue :
Logged into the MotionEye web interface
Added the MMAL camera
Camera worked perfectly first time
Upped the resolution to 1024x768
The interface hung & I was unable to Putty onto the Pi Zero W
Rebooted the Pi Zero W
Logged back into the MotionEye web interface
Video window was showing a grey screen saying “Unable to open video device”
I tried reducing the resolution back to 640x48 (and even options below) but it still shows the grey screen
Tried rebooting again – still the same

Please tell me how I can revive the connection to the camera.

If I’ve missed out any important info, please let me know.

Thanks muchly.

as far as I can see you opened an issue Motioneye Github as well
This is already the best place as you have the guys developing Motioneye over there.

Yes, I posted there to but I thought I’d post here to in case:

  1. They say it’s a DietPi issue
  2. Someone here has seen the problem before

Hope you don’t think this is spamming, just trying to cover the most sensible bases.

don’t worry. Our developer is part if the MotionEye project as well :wink:
But good to have it on the MotionEye GitHub.

Ha ha, awesome. Clever guy!!

DietPi is the best environment I’ve ever used. So easy to set up and use. Makes the Pi such a useful tool.

This is the first issue I’ve had when using it, and I suspect that it’s something daft which I’ve done that caused the problem!