Mosquitto doesn't run. I can't find out why.

I am new to the DietPi world. I downloaded an 8gb image of V 149 from YouTube - Andreas Spiees, who configured his using the script he downloaded from Pete Scargill It seems like the perfect collection of tools to do IoT stuff. But Mosquitto doesn’t work. I see Mosquitto server start up as the Pi Zero W boots. Then, when I try to use it with the following instruction “mosquitto_sub –d –t hello/world”, I get the following: “Error: Connection Refused”

I tried the pub/sub tests with a Raspbian light instance, and it worked. I searched DietPi forums for Mosquitto, Mosquitto config, MQTT, and a variety of other related words to see if there are any clear outlines of how Mosquitto is installed and configured on DietPi, but there is nothing, except some indication that Mosquitto doesn’t run under V 159 (which I just updated to, hoping it might solve the problem).

When I read some of the other threads, they are too terse for me to follow, obviously contributed by people who know what they are doing. I don’t. Where can I get help to:

  1. step through confirming that I have Mosquitto properly installed and configured in DietPi?
  2. lock it down so that it uses SSL certs?

Many thanks in advance to any/all who take pity on me and want to see another successful DietPi user.

ps. I ran the new “dietpi-services status” and it told me that cron, proftpd, apache2, and mosquitto are inactive (dead), even though I thought I saw it start up. Does this info help explain why?


Mosquitto is resolved for v6.0,
NB: ARMv6 is untested (i’ve only tested RPi 3 ARMv7 and C2 ARMv8). If any issues with the below image, let us know and i’ll investigate.

For now, you’ll need to download and use the updated RC v6.0 image:

v6.0 will be officially released next week.

Thanks for the reply and links, Fourdee.