Mine OS installation problems

I thought I’d try installing Mine OS on a spare Pi4/4GB to satisfy my kids’ multiplayer dreams, and because setting up a download center on another Pi4 was so easy with DietPi.

I’ve set static IP for the MIneOS card, can SSH, and access the config/install console for DietPi. I have only installed MineOS from the Optimised Software section. After install and reboot, I can’t access MineOS server through port 8443; “err_empty_response”, which seems to be telling me that MineOS isn’t running.

looking up in the install screens in Putty, I see this near the bottom:
"writing new private key to ‘.tmpkey.pem’

writing RSA key
error: <class ‘socket.error’>, [Errno 2] No such file or directory: file: /usr/lib/python2.7/socket.py line: 228"

there are numerous “cast between incompatible function types” warnings further up in the install, if that matters?

{“level”:“info”,“message”:“Starting up server, using commit: 4470b92 corrected -d base_dir not being extracted properly\n”,“timestamp”:“2020-06-14T16:42:04.522Z”}

Appreciate any help with next steps to get this running…

TIA, Erik


I tried installing MineOS in my RPI3B+ and have seen the same messages. However I’m able to access the system using https


as well I see node application LISTEN on port 8443

root@DietPi3:~# lsof -i -P -n | grep LISTEN
dropbear 436      root    3u  IPv4  12299      0t0  TCP *:22 (LISTEN)
dropbear 436      root    4u  IPv6  12300      0t0  TCP *:22 (LISTEN)
java     512 ubooquity   44u  IPv4  13323      0t0  TCP *:2039 (LISTEN)
java     512 ubooquity   52u  IPv4  13328      0t0  TCP *:2038 (LISTEN)
node     542      root   11u  IPv4  12541      0t0  TCP *:8443 (LISTEN)

thank you for the reply.

I tried Cuberite also, which is working fine, although a little clunky to administer. Not sure if that’s what I’m going to go with or not, but am still interested in getting MineOS fuknctional. Unless Cuberite is sooooo much better, in which case I won’t bother. Probably going to set up a bedrock-based server also at some point, since most of my kids’ friends play through iOS.

But anyway, I had uninstalled MineOS when I got Cuberite working so easily, so I just reinstalled it, and am still getting no response from-----

OK, stupid me just tried https.

Ok, it seems it’s working just fine over https. All previous attempts were http.

Color me stupid.
And thanks for the help.


Yes you need to use HTTPS to be able to connect to MineOS. :sunglasses: