micro SD card stuck busy

RPi 3B. I installed DietPi, now the SD card is corrupted. When I try to boot from it dietpi reports it is stuck in busy mode. When I try to re burn dietpi or any other OS it is reported as write protected.

I have tried using windows diskpart to remove write protection.
I have tried gparted to remove the partitions and start over. gparted reports operations done but the partitions and data are still there.
I t6ried minitool partition magic to repartition and format the card, it reports all operations success; all data still on card.
I can mount the ext4 partition.
I am interested in saving the card not the data.

So far the only thing I have accomplished is making the boot partition unreadable, maybe reformatted, maybe just moved out of range.

From hours of GoOgling I seem to be the only one. Any help appreciated.


many thanks for your request. Did you tried using Etcher to flash a new copy of DietPi on the SD card? Usually Etcher will run a verification afterwards to check if all went fine.

Yes, I tried Etcher, SD card formatter. Libreelec SD maker, RaspberryPi SD maker, Rufus, Win32imager and a couple others.

On another note; I tried to reburn the working SD card (because something is going on with permissions, I wanted to start over) it would not burn.

Raspberry Pi imager takes a very long time and returns a verification error contents not the same as written.

SD formatter says it formatted, but everything is still on the card. gparted says it deleted the partitions and re wrote them, but they are still there.

Dietpi has eaten 2 SD cards, maybe a third. This is getting expensive! No more SD cards.

Well I’ve burned DietPi RPi image a 20-30 times to a single SD card without issues over the last month. As well there are a lot of user using it. I don’t believe it can do any physical damage.

This install was to a Pi3B with the OS on a HD. The (cheap POS) powered USB port suddenly stopped providing power to the HD. After that the SD card is “frozen”; I can edit files on it and apparently save them but on refreshing the files revert to their earlier version. I can try to format the SD and SDFormatter reports success but all of the files are still there.

I tried to burn an image using Etcher, it reported a successful burn to “1 failed device”. No change to the files on the SDcard.

I have tried the regedit trick on windows with no resolution. I can read the card, can’t write to it.

fsck reports

Superblock needs_recovery flag is clear, but journal has data.

Probably you would need to consider that your SD card is broken