MCE Remote mapping with Kodi (RPi3)


I have a Microsoft MCE Remote I was previously using in my old HTPC with windows (and KODI). Now I move to Kodi with Raspberry PI3 and diet-pi (I love it) and I want to use continue using the remote (despite the IR receptor is bigger than the raspberry hahaha).

Just by plugging the receptor, in Kodi, a little keys are working, but I want to be able to make fully functional.

What is strange, is that lirc is not installed by default, but the remote is working. In fact, I tried to install and the remote stop working.

What should I do to have a full working remote with all (or most of them) buttons working on kodi? Try again with lirc and make all the mapping?

Also, I’m curious about how is working the remote just with plug&play without lirc installed…


If you have a original “Microsoft MCE Remote” with a “Microsoft eHome Infrared Transceiver” it is a HID device (Human Interface Devices).
Such as a keyboard or mouse. It work as same as you will hit keys on your keyboard, which is connected to your RPi running Kodi.

You have to “remap your keyboard”, need to configure it to simulate keyboard key-presses.
Better to say, edit your key mappings for “Microsoft MCE Remote”.

I personally use a “FLIRC” with a TV remote. FLIRC is as well recognised as a HID.
Easy way for me was to install and use Kodi Add-on : Keymap Editor

Don’t know for sure, if it will work with a “Microsoft MCE Remote”

Yes, that’s correct. It’s possible to use LIRC with “Microsoft MCE Remote” but it’s a pain:

Yeah, thats my case!

I have tried with Keymap Editor addon but I can only change the buttons that already work (key arrows and just a few more). The other amount of keys are not been recognized.

In windows I use MCERemote addon and worked perfectly, but it is only available in windows :frowning:

So, it seems my only change it’s to try with lirc…and it really seams like it’s gonna be a headache hahaha

I have come to a solution (quite simple, actually), so, if it helps someone…

I just installed lird
Then, with Keymap editor addon, all my buttons where working, so I set up the ones I more use.

And thats it :rofl: :rofl: :rofl:

Sometimes I am having weird behaviour, like if a random button was press continously, but I dont know if it is raspberry (software issue) fault or remote fault…