MATE installation

Good morning, everyone,
I did a clean install on an RPI4 4gb ram.
At the end of the installation I have upgraded the system and then selected the MATE installation.
The installation, tried twice with the same result, failed with the errors you can see in the images below



Hey dodo, is it possible to post bigger pictures, I can’t read s*it in the first free ones. :slight_smile:

No stop posting pictures. They are that bad quality. If possible try to connect using SSH and copy terminal output directly. I’m going to delete your 2nd post as it is a duplicate of the first one.

But anyway. Your system is not booting at all currently? Correct? You are ending on a kernel panic message? Correct?

My system won’t boot at the moment. Kernel Panic
Obviously ssh doesn’t work either.
Sorry for the quality of the photos and the double post

Sorry to say but best would be to start with a new image. Try to complete the first install first to see if system is working afterwards. In parallel I did a test to install mate and it was working without issues. Means, it should work.

I redid the installation from scratch and now everything works.
If you want I can try to do the mate installation again but I’m afraid it will crash like it did before. I am using the image DietPi_RPi-ARMv7-Bullseye.7z

As said, a test install on my RPi4B was working without issues. Just give it a try. :smiley:

i am trying again. i will tell you later

I redid everything.
the installation seemed to go well until the end. Dietpi asked me what I wanted to run at boot and I left CLI. After boot kernel panic as in the attached picture.

Are you using SD card? If yes, could you try a different one? Or install directly on a USB pen stick for testing?

I’ll try a different SD. If that doesn’t work I’ll try directly on a USB

With a different SD the installation reaches the end without any problems. I performed the reboot but then with startx I get the following error

a small update…
if i use the user dietpi, startx does not work. if i change the user to root mate it starts fine

Use sudo startx. I guess user dietpi has insufficient permission

I did and it works
Thank a lot

Keep an eye on the SD card failing first. It might be a dying one.

Thank you!
maybe a stupid question… how can I check if an SD is about to break?

you would need to place the SD card as additional drive (SD to USB connector) on a running system. There you could try to run some checks like

fsck -a /dev/sdxx

Where you need to replace xx with the actual drive name

But as you had some issues with this card, it looks like dying.