lxde + kodi

Odroid n2+ installed with odroid n2 image

how can i get lxde and kodi running?

x server error no desktop is working


pls can you share the log file that is specified on your error message

here is the log file, hope this helps?
Xorg.0.log (5.16 KB)

There is following error message

[    20.444] (EE) Failed to load module "fbdev" (module does not exist, 0)

hmm could you try following

apt install xorg-xserver-video-fbdev

And test again after a reboot?

We had a similar case but it was more on Raspberry Pi devices https://github.com/MichaIng/DietPi/issues/4175

i looked at the link this was the link:
apt install xserver-xorg-video-fbdev

and yes it works now i have a desktop!

Thnk for your help

good it is working now. What is the version of DietPi you are running actually?

version V7.3.2

thnx again!

ok thx for sharing.

no when i start Kodi from the desktop the screen is squeezed to the right side and freezes?

kodi error log:
kodi_crashlog-20210705_120258.log (26.9 KB)

Please try to start it from console (outside of an desktop session) via kodi --standalone.

when i start it from console the same thing happens: see the picture

this is still lxde desktop. can you go back into command line?

this was the result on my tv screen when I run it from the command line

could you try running dietpi-autostart 1 and reboot your system afterwards

Can you also please verify that these packages are installed:

dpkg -l malig52-fbdev-opencl-odroid aml-libs-odroid kodi-aml-fbdev-odroid

Kodi should then start independently from any desktop or X server.

For the desktop, did try to start it as root user? Also can you show the following output:

ls -al /dev/dri

But it actually makes sense as the GPU/driver packages for Kodi all use the framebuffer, so I guess it is expected the KMS/DRM is not available. I’ll add those packages for desktop/X server installs on Odroid N2 (and C4, which behaves the same way) accordingly.

I get the same screen squeezed then turns to black no output

all packages are installed

when i run

ls -al /dev/dri

Module                  Size  Used by
xt_nat                 16384  38
xt_tcpudp              16384  50
xt_conntrack           16384  2
nft_meta               16384  90
ipt_MASQUERADE         16384  8
nf_nat_masquerade_ipv4    16384  1 ipt_MASQUERADE
nf_conntrack_netlink    45056  0
nft_counter            16384  89
xt_addrtype            16384  2
nft_compat             20480  100
nft_chain_nat_ipv4     16384  36
nf_conntrack_ipv4      20480  3
nf_defrag_ipv4         16384  1 nf_conntrack_ipv4
nf_nat_ipv4            16384  1 nft_chain_nat_ipv4
nf_nat                 32768  3 xt_nat,nf_nat_masquerade_ipv4,nf_nat_ipv4
nf_conntrack          143360  6 nf_conntrack_ipv4,nf_conntrack_netlink,nf_nat_masquerade_ipv4,xt_conntrack,nf_nat_ipv4,nf_nat
nf_tables_ipv4         16384  45
nf_tables              86016  279 nft_chain_nat_ipv4,nft_compat,nf_tables_ipv4,nft_meta,nft_counter
br_netfilter           24576  0
bridge                155648  1 br_netfilter
stp                    16384  1 bridge
llc                    16384  2 bridge,stp
overlay                53248  12
mali_kbase            462848  0
i2c_meson_master       20480  0
amvdec_vp9            122880  0
amvdec_vc1             65536  0
amvdec_real            45056  0
amvdec_mmpeg4          40960  0
amvdec_mpeg4           65536  0
amvdec_mpeg12         106496  0
amvdec_mmjpeg          28672  0
amvdec_mjpeg           40960  0
amvdec_h265           147456  0
amvdec_h264mvc         57344  0
amvdec_mh264          159744  0
amvdec_h264_4k2k       69632  0
amvdec_h264           147456  0
amvdec_avs             69632  0
stream_input          180224  9 amvdec_h265,amvdec_mh264,amvdec_h264mvc,amvdec_h264_4k2k,amvdec_real,amvdec_vp9,amvdec_h264,amvdec_mpeg12,amvdec_avs
decoder_common        188416  15 amvdec_h265,amvdec_mjpeg,amvdec_mh264,amvdec_mmpeg4,amvdec_h264mvc,amvdec_mmjpeg,amvdec_h264_4k2k,amvdec_real,stream_input,amvdec_vp9,amvdec_h264,amvdec_mpeg12,amvdec_avs,amvdec_vc1,amvdec_mpeg4
firmware               28672  16 amvdec_h265,amvdec_mjpeg,amvdec_mh264,amvdec_mmpeg4,amvdec_h264mvc,amvdec_mmjpeg,amvdec_h264_4k2k,decoder_common,amvdec_real,stream_input,amvdec_vp9,amvdec_h264,amvdec_mpeg12,amvdec_avs,amvdec_vc1,amvdec_mpeg4
media_clock            45056  10 amvdec_h265,amvdec_mh264,amvdec_h264_4k2k,decoder_common,firmware,stream_input,amvdec_vp9,amvdec_h264,amvdec_mpeg12,amvdec_avs
ip_tables              32768  0
x_tables               49152  7 xt_nat,ip_tables,nft_compat,xt_tcpudp,ipt_MASQUERADE,xt_addrtype,xt_conntrack
ipv6                  462848  247 bridge

root@DietPi:~# ls -al /dev/dri
ls: cannot access '/dev/dri': No such file or directory

are there other things i can try?

I’m deeply sorry for not replying here. We have a new mainline kernel based Odroid N2(+) image now, which has KMS/DRM support, so should work well with LXDE and Kodi now. Sadly old systems cannot be upgraded, since the new bootloader requires a different partitioning with a single ext4 partition only, no dedicated FAT boot partition. So the image needs to be newly flashed.