Long boot time caused by a wait after the hostname setting


I just ‘resolved’ a problem with my dietpi installation.
to resume : at boot after the system set a hostname, i had a 1min + delay.
the solution : remove unused entry from /etc/fstab

That was caused by a noob error, i mounted a usb key with dietpi-drive_manager, then never plugged it back.
i tried to unmount it from dietpi-drive_manager, the fstab entry persist.

i wasn’t sure where to put this, as it is a half a tips/half a bug and half a noob mistake…

edit : corrected not understandable sentences (not native english)


Many thanks for your report. Actuall unmounting a drive via drive manager should comment (thus inactivate) the fstab entry, so it should not cause a boot hang.

Actually would be great if we’d find a way to let systemd ignore missing drives faster and go on with boot. We already add “nofail” mount flag, so it will at least go on with boot, but not nice that it waits that long…