Log full with "rk3x-i2c timeout"

Hello everyone, this is my first post in this forum and I need your help.
I installed DietPi on my Nanopi M4 and it works fine but in the log I discovered that every second the following line

kernel: rk3x-i2c ff3d0000.i2c: timeout, ipd: 0x80, state: 2

I looked for a similar problem here in the forum but didn’t really find anything.

I have to mention that I use a SATA HAT, maybe that’s why this problem occurs, I have no idea why the error appears every second.
The system is running Openmediavault 7 but this error occurred before I had installed omv.

The power supply I use has enough power, the system ran on Armbian for a few years until I switched to DietPi.

More information:

cat /boot/dietpi/.version
G_DIETPI_VERSION_CORE=8
G_DIETPI_VERSION_SUB=25
G_DIETPI_VERSION_RC=1
G_GITBRANCH=‘master’
G_GITOWNER=‘MichaIng’

echo $G_DISTRO_NAME $G_RASPBIAN
bookworm

uname -a
Linux omv 6.1.63-current-rockchip64

I would be very happy if someone has a solution for me

Hello again, I found the solution to the problem here https://dietpi.com/forum/t/dietpi-i2c-problem/66
I don’t need i2c, so I disabled it with raspi-config.

To install raspi-config on the DietPi use the script here: https://github.com/EmilGus/install_raspi-config

Thanx @all

You can enable and disable i2c also via dietpi-config :slight_smile:

Thank you for the answer @Jappe
Unfortunately I didn’t find such an option in dietpi-config.

Can you please be more specific?

I have to correct myself, under advanced options you can set UART, I2C, SPI etc pp. not for all devices, but for example RPi, OPi Zero 3 and some more.
But it’s interesting that raspi-config, which is also RPi only, works for the NanoPi.

When I compare raspi-config to dietpi-config then the two scripts do basically the same for I2C, they add dtparam=i2c_arm=on to /boot/firmware/config.txt but raspi-config does also a modprobe i2c-dev.

If your are motivated you can implement this into the DietPi script :smiley:

Maybe something for @MichaIng to have a look if we can enable I2C management on this board as well.

But it is clear that the image for NanoPi M4 is missing this function in the dietpi-config :wink:

That’s why I gave a ping to our developer :wink:

Perfect, thank you @Joulinar :handshake:

Sorry for the late reply. raspi-config did even install and start on a NanoPi M4? :thinking:
The /boot/config.txt of course does not exist there, and the overlay it aims to use is RPi-only.

So the problem is that the I2C kernel module is triggered, even that ni I2C device is attacked? I guess the HAT is the reason for this. It should work to just blacklist the module, and this is probably what raspi-config did.

Check /etc/modprobe.d for a related file. It would contain blacklist i2c-dev. Probably it is an alias, but more fitting would be blacklist rk3x-i2c.