lighttpd in v6.24.1

After running the update 3 times from v6.18 to v6.24.1 the update breaks lighttpd resulting in a client error of 503 - Service Not Available. Why is this?

Started with the AlloGUI RPi image.

Which RPi version do you tried this?

Please paste:

journalctl -u lighttpd
cat /var/log/lighttpd/error.log

I am running v6.24.1

root@DietPi:~# journalctl -u lighttpd
– Logs begin at Tue 2019-05-28 01:21:02 BST, end at Tue 2019-05-28 01:38:30 BST
. –
May 28 01:35:20 DietPi systemd[1]: Starting Lighttpd Daemon…
May 28 01:35:20 DietPi systemd[1]: Started Lighttpd Daemon.
root@DietPi:~# cat /var/log/lighttpd/error.log
2019-05-28 01:35:20: (log.c.217) server started
2019-05-28 01:35:36: (mod_fastcgi.c.1926) connect failed: No such file or directory on unix:/run/php/php7.3-fpm.sock
2019-05-28 01:35:36: (mod_fastcgi.c.2842) backend died; we’ll disable it for 1 seconds and send the request to another backend instead: reconnects: 0 load: 1
2019-05-28 01:35:36: (mod_fastcgi.c.1689) all handlers for /index.php? on .php are down.
2019-05-28 01:35:38: (mod_fastcgi.c.2686) fcgi-server re-enabled: unix:/run/php/php7.3-fpm.sock

Looks like PHP-FPM is not running.

Please try if this solves the issue:

systemctl restart php7.3-fpm
systemctl restart lighttpd

Please report if the first command takes very long or even times out with an error. If so, most probably its a known entropy issue. Please see here for solution:
If this indeed works, please send a dietpi-bugreport and paste the ID here. I want to collect affected systems to ship the workaround for next DietPi update.