Latest odroid C1 image 6.22 doesn't work!

Installed the image 10 times and downloaded it 10 times on my eMMC

Every other image (Ubuntu mate and minimal) just works…

I see the odroid booting up and initializing network but no ipadress is to be found on my network… have no screen and can’t see what’s wrong.

Who can help me please, I really love dietpi and I cannot use it now…

Ps. Sdcard does work!

Details
Odroid C1 (not C1+)
Emmc card 8gb for boot

No video output
No serial cable to verify boot process…

to be clear:

eMMC:
Works:

  • Ubuntu Mate (GUI
  • Ubuntu minimal (headless)

Doesn’t work:

  • DietPi

SDCard:
Everything works (alle images)

When i install on my sdcard and dietpi “works” i cant see the temps of the cpu nor can i change CPU governor (doesn’t recognize CPU correctly?!)

Previous install of Dietpi worked as a charm but i wanted to start over because it was an old install of dietpi.

Is there an beta image that i can try?

Does anyone else have this problem?

Hi,
Many thanks for your report.

Currently all images will be updated and re-created with current DietPi version. Unfortunately your system is not done yet. You could follow the topic on GitHub

https://github.com/MichaIng/DietPi/issues/2979

I have the same problem.

But i wonder why it then says “stable” on the download site.

guys,

pls can you test new C1 image v6.28 (in testing) based on Armbian

https://github.com/MichaIng/DietPi/issues/2979#issuecomment-581186211

If there is an issue with the new image, pls report it back on GitHub. That will help to improve the image and experience for other user as well.

Many thanks in advance

What kernel is that?

I just bought the C1+ and just found out there is no real support anymore.
From looking around it seems like everything after kernel 3.10 has problems and stuff like HDMI is not working?

I just flashed the Hardkernel Ubuntu 18.04.3-3.10 minimal for testing.
I wonder what the drawbacks are with such an old kernel if everything is working?
I also wonder that this works because isn’t 18.04 kernel 4+

Not sure what kernel is used exactly. but the base image is Armbian

This I found on Armbian WebSite

https://www.armbian.com/odroid-c1/

The Armbian guy is mad at me:
https://forum.armbian.com/topic/12859-odroid-c1-images/

I’m just looking for a working stable image.
Maybe my English is not good enough to understand it.

As I said, try the new image that was created and have the testing flag right now. If there are issues you can report back on GitHub.

The latest also does not work. Black screen…
I reported it on GitHub.

So i tried Jessie from here: REMOVED OBSOLETE LINK
But after login i get:

-bash: /DietPi/dietpi/login: No such file or directory
-bash: /DietPi/dietpi/func/dietpi-globals: No such file or directory

and nothing works.

I have different boards (RPi 3, RPi Zero, BananaPi, C2) and this C1+ is the first one where i have this problems.

Jessie is not supported by DietPi anymore.

But back then it was a working image?


DietPi Odroid C1 Buster - Downloaded 2020.02.06

Black screen and the blue LED is just always on


DietPi_v6.22_OdroidC1-ARMv7-Stretch

Black screen and blue LED constantly flashing
Not showing up in DHCP


DietPi_v6.0_OdroidC1-ARMv7-Jessie

After login:
-bash: /DietPi/dietpi/login: No such file or directory
-bash: /DietPi/dietpi/func/dietpi-globals: No such file or directory


Armbian_5.38_Odroidc1_Debian_jessie_default_3.10.107

Works


Hardkernle Ubuntu-18.04.3-3.10-minimal-odroid-c1-20190923

Works

Okay, so just to focus testing/debugging:

  • Debian Jessie it nothing we further support, hence I’m not going to digging into this, as long as it is not an old system that was running Jessie since when it was still supported.
  • Kernel 3.10 images is not something we can use, because Debian Stretch basically requires Linux 3.16, and we want Debian Buster. This was also the reason why we moved from Meverics old Jessie image to Armbian as basis.
  • The current v6.22 Stretch image is up for a long time. So actually that should boot fine. Although I have no detailed download statistics but definitely would expect some more reports if that failed in many other cases as well.
  • However we want Buster where possible, hence I would like to concentrate on the current Armbian Buster based image.

spanx20
For you the current stable (Stretch) image works on SDcard? It is the same with the new Buster-based beta image?
I see now the following: https://www.armbian.com/odroid-c1/

Kernel Issues

  • eMMC not supported

Hence it is sad, but we have no acceptable chance to get this working currently. And I also don’t believe that Armbian is going to invest much time to fix things for this device, since it is not even listed in their official devices list: https://www.armbian.com/download/?tx_maker=hardkernel

MrGlasspoole
Found the thread where we discussed the Stretch image that time: https://github.com/MichaIng/DietPi/issues/2561
So yeah, no HDMI output indeed, and that seems to have not changed until now :frowning:. Also the issue is mentioned that reboot hangs with blue light and needs unplug cycle. This sounds like your boot issue, is it probably actually booting but then hangs on some initial reboot? Although there is no automated reboot done on current DietPi, as long as one does not enabled automated firstrun installs… And also this issue has been crossed through on Armbian product page :thinking:.

So what I derive from that is that we need to make the known issues clear on our download page as well. And I’ll verify that correct serial console is enabled + local getty disabled, since no point in having this without video output.

I give up on the C1. No unplug cycle or something else does work.

MrGlasspoole
You mean it does not boot up at all after reboot + plug off + plug on?

Yes

Okay only thing I can suggest for now is trying it with the Armbian image and see if the issue is the same after doing all kernel/firmware upgrades: apt update && apt full-upgrade

Same here, I tried armbian en have run full upgrade…no luck.

I tried ubintu mate and when I boot up it works but after upgrading mate then same problems.

I updated our image. It ships now with the new kernel branch, i.e. Linux 5.9 instead of 5.4. However, the major limitations (no HDMI, no eMMC) remain: https://dietpi.com/downloads/images/

I’m soon going to rebuild everything with the official Debian ARM kernel, instead of Armbian. What I need to learn and test first, is building such images from scratch, including U-Boot compiling, since at least the Debian Amlogic U-Boot package does not support Odroid C1 or any other ARMv7 SBC.

https://packages.debian.org/linux-image-armmp

Likely those will be Debian Bullseye images right from the start, as we do not expect major changes to Bullseye anymore and most things our side are tested and work fine.