Latest HA Update broke Zigbee Stick

Hi. After i upgrade to HomeAssiant 2023.3 my SonOff Zigbee Stick no longer works.
It would be nice, if anyone can help me.
Iam using an Odroid C2.

→ Here are the ErrorLog: Error setting up entry Sonoff Zigbee 3.0 USB Dongle Plus - Sonoff Zigbee 3.0 USB Dongle Plus for zha · Issue #89323 · home-assistant/core · GitHub

“pkg_resources.DistributionNotFound: The ‘zigpy_znp’ distribution was not found and is required by the application”

is it a issue from dietpi or from HA?

sorry for my poor english

G_LIVE_PATCH_STATUS[0]=‘not applicable’


Linux DietPi 6.1.11-meson64 #23.02.2 SMP PREEMPT Sat Feb 18 00:07:55 UTC 2023 aarch64 GNU/Linux

Odroid C2 (aarch64)


Please try to (re)move the dependencies directory:

systemctl stop home-assistant
mv /mnt/dietpi_userdata/homeassistant/deps /mnt/dietpi_userdata/homeassistant/deps.bak
systemctl start home-assistant

HA reinstalls them on service start and when accessing related integrations. We’ve seen other cases where conflicting dependencies among HA and the individual integrations, as well as when Python itself is upgraded (via reinstall) are causing such kind of problems.

i have tried this, but unfortunately i got the same error.

I have the same issue; I upgraded to 2023.3.1 a couple of days ago and experienced the issue, upgraded to 2023.3.2 yesterday morning and to 2023.3.3 right now, but nothing changed. I tried to rebuild deps as MichaIng showed, but nothing changed as in5tall87 already confirmed

I just updated dietpi to 8.15, then reinstalled home assistant (sudo dietpi-software reinstall 157), went through the usual process (wait for htop to show usage < 100 for home assistant, restart home assistant service, wait again, restart ha service) and now it seems to work again. I think maybe it was related to the bug in the virtual environments solved il 8.15
I will monitor my environment to see if it works as expected in the next few days

We added the enhancement as already described above Latest HA Update broke Zigbee Stick - #2 by MichaIng

Well, actually I executed the commands in that post on 8.14 with HA 2023.3.2, but it did not solve the issue. I performed the reinstall after upgrading to 8.15 and it solved. Maybe there was something else that got rebuilt with the reinstall.

In any case what matters (at least for me) is the result, and the result is that your work solved the issue :slight_smile: great support as ever

yes! Issue is gone by update to the newest DietPi Release and then reinstall HA.
Thanks Devs :slight_smile: