KVM boot error

I downloaded the DietPi BIOS IMG file and I am attempting to get it to boot in KVM and I get this error. Any ideas?

I have already resized img file to 10 GB and made no other changes to the default settings in KVM. I found a few similar issues on the web but nothing has worked so far…

For future reference the post by LeoFender got it going


I was not able to do it with img file (probably don’t know how to resize it properly)

I had to start with VBox and work it backwards from there…


sorry for the late response but it took some time for me to get a Linux system up and running to have KVM installed. At the end I had a Windows computer hosting Ubuntu inside VirtBox. And this Ubuntu VM was hosting my KVM system :smiley:

Long story short, I had the same issue using x68 image file. However I worked around stating with a plain Debian installation and installed DietPi on top using PREP script.

Thanks Joulinar,

I considered doing that after seeing the prep script on Github during my searches. Probably faster to resize via vbox image. Maybe when I get a free moment ill check out resizing a raw image and maybe do a tutorial. I have a feeling that’s where the problem was occurring. Kinda funny that we’re running Debian based DP and yet no KVM VM option! Oh well, no biggie!

Check out the forum link i posted, it’s pretty good to get it going from the vbox OVA file.

I guess I will talk to developer. Probably it can be added to VM section. Will see.