Kodi won't start - Odroid C2


I’ve tried several reformats and reinstalls and I can’t seem to get Kodi to start on my Odroid C2.

When I open through the ‘startkodi’ command I receive the following error message:

X.Org X Server 1.16.4
Release Date: 2014-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.16.0-4-arm64 aarch64 Debian
Current Operating System: Linux DietPi 3.14.65+ #1 SMP PREEMPT Wed Jun 8 13:42:47 CEST 2016 aarch64
Kernel command line: root=UUID=e139ce78-9841-40fe-8823-96a304a09859 rootwait rw console=tty0 no_console_suspend hdmimode=1080p60hz m_bpp=24 vout=dvi fsck.repair=yes net.ifnames=0 elevator=noop disablehpd=true
Build Date: 11 February 2015 01:19:23AM
xorg-server 2:1.16.4-1 (> Debian -- User Support> )
Current version of pixman: 0.32.6
Before reporting problems, check > http://wiki.x.org
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Tue Jun 28 12:47:08 2016
(==) Using system config directory “/usr/share/X11/xorg.conf.d”
X: …/…/…/…/include/privates.h:122: dixGetPrivateAddr: Assertion `key->initialized’ failed.
xterm: fatal IO error 11 (Resource temporarily unavailable) or KillClient on X server “:0”
xinit: connection to X server lost

When I try to load using the command ‘kodi’ I get:

/usr/local/bin/kodi: 18: /usr/local/bin/kodi: pulseaudio: not found
ERROR: Unable to create GUI. Exiting
*** Error in `/usr/local/lib/kodi/kodi.bin’: munmap_chunk(): invalid pointer: 0x0000000002b1f938 ***

Does anyone have any idea what might be the cause of these errors? Happy to provide more information if it will help.

Everything else is working great and is easy to use.


Hi Gabba,

Thanks for the report. Yep this appears broken at the moment.
As far as I’am aware we havn’t changed the installation code, so it could be related to GPU driver devolpment. I’ll contact Meveric (kodi-odroid package is his) and see if anything has been changed.

Git Ticket: https://github.com/Fourdee/DietPi/issues/399

Thanks for all the effort you’ve put in Fourdee, I’ll update DietPi tonight and let you know how it goes.


Hi Fourdee,

With the recent update, I am getting the same error as I was when I first made this thread. Otherwise, it had been working well (if not super quick in the menus but I suspect that this was due to my folder structure).

Hi Gabba,

Thanks for letting me know. I’ll take a look.

Can you please tell me what kernel version your running:

uname -a

Edit: Kodi works for me on v125 and kernel ver:

root@DietPi:~# uname -a
Linux DietPi 3.14.65+ #1 SMP PREEMPT Wed Jun 8 13:42:47 CEST 2016 aarch64 GNU/Linux
Linux Odroid 3.14.65+ #1 SMP PREEMPT Thu Jul 14 07:59:44 CEST 2016 aarch64 GNU/Linux

Hmm, I haven’t changed anything Kodi related since the update. All i have done is apt-get update and apt-get upgrade but this did upgrade the kernel to a slightly newer version. Is it possible that something went wrong in the kernel upgrade?

Edit: rc.local fails to initialise on startup and if I manually load it samba fails to load.

I tested a fresh install of Kodi with same kernel version:

root@DietPi:~# uname -a
Linux DietPi 3.14.65+ #1 SMP PREEMPT Thu Jul 14 07:59:44 CEST 2016 aarch64 GNU/Linux

Working fine for me.

It may be your running the old (even FBdev) version of Kodi. Can you try reinstalling it with:

dietpi-uninstall KODI

Then select and install Kodi from the menu.

There a few fixes for C2 and Kodi in next update: https://github.com/Fourdee/DietPi/issues/446 & https://github.com/Fourdee/DietPi/issues/447.
You can manually apply these fixes now with:

apt-get install -y libcurl3-gnutls
rm /etc/asound.conf

Hmm, thanks for the ideas. They didn’t work but I did a full re-install and that seems to have fixed it. No idea what went wrong.
Thanks Fourdee!

Hi Fourdee,

I installed VNC4Server (and LXDE by extension) and Build Essentials and they seem to have caused the same Kodi error. Not sure what this means but hopefully it’s useful to you. I’ll just revert back to my backup without VNC.


Hi Gabba,

Thanks for the info.
I’ll create a Git ticket and try to replicate this issue: https://github.com/Fourdee/DietPi/issues/454

Thanks Fourdee, all is working well now!