KODI will not install on ARMv8-Buster RPI 3 B+

Completely clean install and I get the following during Instal of Kodi:

APT install for: libcec4 libcurl3-gnutls libnfs12 kodi fbset │
│ - Command: apt-get -qq --allow-change-held-packages install libcec4 │
│ libcurl3-gnutls libnfs12 kodi fbset │
│ - Exit code: 100 │
│ - DietPi version: v6.31.2 (MichaIng/master) | HW_MODEL: 3 | HW_ARCH: 3 | │
│ DISTRO: 5 │
│ - Image creator: DietPi Core Team │
│ - Pre-image: Raspberry Pi OS (64-bit) │
│ - Error log: │
│ E: Unable to correct problems, you have held broken packages.

Any help would be appreciated.



many thanks for your report. Pls can you try running apt update && apt upgrade

All zeros returned. Same results when I try to install Kodi.

Thanks for the help.

All zeros returned.

what does this means?

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

After running: apt update && apt upgrade

pls do apt install libcec4

libcec4 is already the newest version (4.0.4+dfsg1-2+rpi1+rpt1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

and trying to install Kodi will bring same error message still?

Yes, Same result.

ok issue is with Kodi package 18.7 on Raspberry OS 64bit. It doesn’t seems to be available on Debian repository


using 32bit image instead, and kodi should be working

Yep, That was it.


I wonder if anyone have sucessfully installed KODI on the ARMv8-Buster and Raspberry Pi4?
I know it works fine on the 32 bit OS version but having 4GB or more RAM in the Pi4 makes the 64 bit must faster in many applications. The KODI GUI itself could run faster while navigating and playing something at the same time

This is an issue outside DietPi. Best to my knowledge, still something to be implemented by RPI Foundation on Raspberry OS 64bit Beta. Btw you can use the 4 GB ram as well on a 32bit system. Ok not with a single process but in total the system is able to utilise the 4GB with multiple processes without issues.