Kodi not starting good (RPi) SOLVED


I’ve got a Raspberry Pi 1 (B model) where I installed the latest version of Dietpi.
In the menu I have chosen to install Kodi wich was installed without errors.

After the reboot Kodi is booting but only the background. The menu isn’t showing at all.

Is this a known problem or do I have do to something else?


Hi Asterion,

Thanks for the report and letting us know.

How are you launching Kodi?

  • Did you apply the autostart option when asked after selecting Kodi for installation?
  • Are you running xinit kodi or something similar from command line?

You can check and change the autostart option in DietPi with:


Hi Fourdee,

I’m launching Kodi via the autolaunch option after installation of Kodi.
It asked me to set the autoboot option, wich I did.

Then it rebooted properly and was starting Kodi and stopped when it loaded the background.

I didn’t do anything else, not even ‘xinit kodi’ from the command line.

Hi Asterion,

Thanks for the info.

I just tested on RPi 3 and all seems fine with Kodi. I’ll run my RPi 1 256MB and re-test.

Tested on RPi 1, kodi working fine, although it took a long time to load.

I’d like to see your system settings, might be the cause (eg: GPU memory split etc). Please can you send me a bug report: https://dietpi.com/forum/t/send-dietpi-a-bug-report/421/1

Kodi has started!

It took quite a few hours or maybe a day to load.
Very strange that it took so long to boot.

A month ago i didn’t ad this problem after a fresh install of Dietpi en Kodi.

I did a bug report and the reference code is

Reference CODE: a963970f-d3e7-43cf-8c72-55a282187aa9-0

I’m back again with this problem but this time i’ve managed to find te problem and solution.

I had to reinstall the whole image.
After the fresh install i installed Kodi again and again, kodi wasn’t booting. Even after 3 days uptime!

I think i’ve found out where the problem is.
Standard, the RPi is overclocked to 900Mhz. I’ve set the settings to 700Mhz and guess what!
After the reboot Kodi started up and is working much faster and much more responsive.

Now we have to find out if this is a problem with Dietpi or with Kodi?


Intresting. The 900mhz clock on the RPi 1 was officially endorsed by RPi foundation years ago. It should be stable and i’am yet to see it ever fail.
It could possibly be a unstable/faulty PSU is causing these issues. I doubt it would be heat related as the RPi 1/2 runs alot cooler than the RPi 3, lots of headroom. Either way, you can check the temps with:


Which PSU are you using? Have you tried others?

I’ve bought the rPi from a friend of me.

He ordered it online with a memory card, wifi dongle en PSU at the same time wich all were qualified to work with the rPi.
Everything was working fine, only Kodi was not booting correctly.

I should try it with another OS and see what difference it would make.