Kodi addons not working

Required Information

  • DietPi version | G_DIETPI_VERSION_CORE=8
  • Distro version | Bullseye
  • Kernel version | Linux DietPi 5.15.61-v8+ #1579 SMP PREEMPT Fri Aug 26 11:16:44 BST 2022 aarch64 GNU/Linux
  • SBC model | RPi 4 Model B (aarch64) (4GB)
  • Power supply used | 5V 3A
  • SD card used | Toshiba 16GB

I’m trying to set my media center with DietPi, but the Kodi addon “Luar”, which just is an installer for other addons, refuses to work.

The installation method is simple, you just need to add “https://luarsource.github.io/Fuente/” as a File manager source, and install the addon as zip (first the files that are inside your kodi version folder, and later the one that is on root).

The addon apparently gets installed but when trying to open it nothing happens.
This are the only errors that I can find on Kodi log:

2022-10-24 18:57:57.359 T:1796    ERROR <general>: GetDirectory - Error getting /usr/lib/aarch64-linux-gnu/kodi/addons
2022-10-24 18:57:57.359 T:1796    ERROR <general>: GetDirectory - Error getting special://xbmcbin/addons
2022-10-24 18:58:13.303 T:1867    ERROR <general>: GetDirectory - Error getting plugin://script.luar/
2022-10-24 18:58:13.333 T:680     ERROR <general>: CGUIMediaWindow::GetDirectory(plugin://script.luar/) failed

I guess this is more a question for the kodi forum than ours. I found something similar. At least an issue with addons. Can you check the availability of /usr/lib/aarch64-linux-gnu/kodi/addons directory? Error getting special://xbmcbin/addons Where does your addon is installed in?

I looked for similar problems in Google and just found that it may be something wrong with Kodi and python version, however I downgraded the last one and still the same.

The add-ons gets installed in /home/user/.kodi/add-ons
The directory you mention is not available so I just created a symlink from there to where the add-ons get installed, but just give me some other errors in the log and the same nule response from the add-on.

Came here to ask instead of a Kodi forum because the add-on I mention works perfectly in other rpi4 distros with the same Kodi version, so I thought it was more probable to find people here with the same problem.

Thanks for your answer!

Does this include Raspberry Pi OS 64-bit? Because DietPi installs the exact same Kodi package.

No, in fact the only other OS I tried this is Libreelec, where it works.
Tried running it on a Dietpi x64 VM and got the same behaviour.
If I find time and my old Pi3 will try again with dietpi, Raspberry Pi OS and ubuntu server, as long as I cannot mess around anymore with the Rbpi4.

Libreelec is quite dedicated to run Kodi. Not really something to compare with as it is unfair :smiley:

Better to check on RPi OS as it would fit DietPi as we use same package source aso.

Just tried with Raspbian OS Lite and same happens. It looks like a problem with the Special Mappings, so kodi side. Still, I find any solution will post it here.

Do you run Kodi as root or other user?

I have tried both, doing all the process from start.

And you use the correct script(s) for Kodi 19?
The addon or addons you actually want to install with it are not available within the regular addons repo from Kodi GUI (which works fine). I’ll almost sure that the luar installer is the problem, respectively how it is setup using which Kodi version, user etc.

Yes, you can find in the remote directory one folder for each supported Kodi version with the dependencies and the the script itself at root which is supposed to work for all versions, that as I said is working on Kodi 19.4 on other platforms.

Looking into Kodi log, the problem not finding the special directories appears just at Kodi start. However I need to check if that also happens when the addon this script has not been installed yet.

I’m also suspicious about not being just a Kodi thing but also related with the script handling of the Kodi version.

did you manage to fix it? i have the same problem trying to install the same add-on.

Nah. I was setting up that rasp for a relative and didn’t want to delay it more time, so just used Libreelec. I set up a rasp3 I had around but haven’t find the time/will to fix it. However if you make some progress or need some help/testing just ask.

1 Like

We will need to test it. I’ll not find time until January. But would install an addon via Kodi GUI, then check where/how it is installed, and verify that the custom addon is installed the same way/location. And of course logs are helpful, e.g. starting Kodi from SSH:


It will show up on attached screen but logs are shown on SSH session.