Kodi 15.2 for DietPi Wheezy

I have built from source Kodi 15.2 over DietPi Wheezy. Its the last stable Kodi version to replace the installed by dietpi-software.

It has been compiled with CEC support so if you have an adecuate HDMI cable you will be able to control Kodi with your TV Remote.

I have tested it over various DietPi versions (v94, v101, v102 and v103) and it works without known problems.

You can check the install script if you want, after downloading and before installing.

Its for Wheezy. Errors would occur if you try it in Jessie because of building dependencies are not the same.

If you have an old version of Kodi installed you should remove it before installing this one.

Download the file, untar it and ./install as root.

Here is the link: https://www.dropbox.com/s/qj7sa06ae14jo1x/kodi_15.2.tar.gz

Hope you find if useful and you enjoy it.

Hi Dogdayfeer,

This is excellent, thank you for sharing. I’ve been meaning to try this for a while, but as you know, very busy and short on time at the moment.
Hopefully another user can test the installation. If it works, i’d be more than happy to upgrade the DietPi-Software Wheezy Kodi installation to use your version if you like?

Hope some feedback from some user … :blush:

Overwhelming success … :frowning:

Well this might be because openelec is the best option if you want a raspberry pi powered media center.

I have the first raspberry pi model connected to my tv with openelec running on it. It is only used for this one purpose.

i use dietpi on my raspberry pi 2.

2 very different use cases so why mix it up.

To install this, should I first install kodi through dietpi-software? Then remove it and run this install script?

I would like to have this installed and boot to it. From a clean install maybe some user settings and autostart scripts might be wrong or?

Hmm it seems Kodi 15.2 is already available through dietpi-software!

Excellent, thanks!

And does your Tv remote works to control Kodi?

Thanks.

I’ve not modified the Kodi installation code. So its most likely the repo maintainers have updated to 15.2, on Wheezy?

I think nothing has changed. I did a fresh install of DietPi Jessie and still Kodi 14.2 via dietpi-software.

Any news?

Hi Dogdayfear,

I’ve had to put this on the back burner (low priority) as I simply dont have the time available at the moment. Have you tested/tried your Kodi 15.2 with DietPi Jessie v109, is it stable?

Nop. I have tried Jessie for 4 or 5 times over the time. I always find the same problem that I cant solve and is this: I cant shutdown my system with

halt

command. Gives an error about shutting down ssh sessions. And I havent been able to correct it. Belive me I have searched for a solution, googling for hours to solve it but no luck. I cant halt my system. Thats because I always back to Wheezy.

And if I had Jessie I will have to compile Kodi from source for Jessie. Different dependencies for both. I think I would do it. But first I have to feel comfortable with Jessie. And the halt system problem follows me from the beggining of the times. :slight_smile:

Solved the ‘halt’ problem. Now use poweroff instead.

So I have to compile from source to Jessie. Mmmm … getting off the mud again. :slight_smile:

I use poweroff also, and reboot commands.

You dont need to recompile for Jessie, its only a suggestion as Wheezy is being phased out (see RPI Wheezy Image section. But if you do, let us know how 15.2 runs on Jessie.

I’m running 15.2 very stable on a RPi2, the only issue that sometimes occurs is that the audio renderer crashes after playing for a long time. When this happens video playback is stuck and you have to reboot.

Are you referring to 15.2 version I compiled or other version?

Thanks.

Not sure, I installed Kodi through the Dietpi menu, so don’t think it’s yours.
I’m running Jessie, yours is for Wheezy right?

Yes, mine is Wheezy.

I dont understand how you are running 15.2 if you installed through Dietpi menu. I think Fourdee still is using and old version of Kodi with the Dietpi install script.

Thanks anyway.

Yep, for wheezy we use the following repo:
deb http://archive.mene.za.net/raspbian wheezy contrib as per Micheal’s guide http://michael.gorven.za.net/raspberrypi/xbmc

Which was 14.x last time I checked (been a while). But the repo may have updated their version, would need to verify.

On RPi Jessie, its a straight forward apt-get install Kodi | from raspbian repo.
Odroids are apt-get install kodi-odroid | packages created by Meveric