Khadas Vim3 Pro onboard wifi

Creating a bug report/issue

I have searched the existing open and closed issues and haven’t found anything related to what i’m looking for, if i missed anything then i apologize.

My vim3 pro has dietpi installed using the conversion script from armbian. I fully understand that this is not a supported device and given that its labeled as “generic” the behavior i’m experiencing is to be expected. I’m hoping that i can use the community’s help to get more support for the device and fix the issue i’m facing at the moment

thanks

Required Information

  • DietPi version |
    G_DIETPI_VERSION_CORE=8 G_DIETPI_VERSION_SUB=25 G_DIETPI_VERSION_RC=1 G_GITBRANCH='master' G_GITOWNER='MichaIng'

  • Distro version | bookworm

  • Kernel version | Linux Neural-Home 6.1.63-current-meson64 #1 SMP PREEMPT Mon Nov 20 10:52:19 UTC 2023 aarch64 GNU/Linux

  • Architecture | arm64

  • SBC model | `Generic Device (aarch64)’ (Khadas Vim3 Pro - Armbian converted to dietpi)

  • Power supply used | 5V 2.5A

  • SD card used | (32G SD card)

Steps to reproduce

  1. attach a USB wifi adapter
  2. restart system

Expected behaviour

  • Onboard wifi should be treated as wlan0 and showing in dietpi-launcher config as onboard wifi

Actual behaviour

  • no onboard wifi is showing as an option, instead, onboard wifi is treated as an adapter and when attaching a usb adapter, the onboard wifi loses connection and needs to be manually configured again as it becomes wlan1 while usb wifi is wlan0

Extra details

  • none that i can think of at the moment but please ask away and i’ll try to provide anything i could

usually adapter name depends on the order they become available for the kernel/os. First one will be wlan0. Means your USB adapter is faster compared to the onboard one.

fair enough, but how do i manage that, as i want to lock wlan0 for the onboard wifi?

so far my google searches have led me to udev rules that i’m investigating but no luck yet.

something worth to mention is that the system seem to any device that isn’t wlan0 into powersaving mode automatically

UPDATE: i was able to get my desired function to work by creating the following file:
/etc/udev/rules.d/99-any-name-you-want.rules

and binding the name to a specific mac address using this template:

SUBSYSTEM=="net", ACTION=="add", ATTR{address}=="00:11:22:33:44:55", NAME="wlan0"

Hopefully that helps anyone looking for this and will let you guys know if this solution is stable.

I am still interested in helping in any way to bring dietpi support to Khadas Vim3

1 Like

we have quite limited resources and are not able to implement support for all SBC. If someone find time, he could start implementing it.