Keyboard not working at random: crng init done

I installed dietpi RPI ARMv6 on my raspberry pi zero w, when the boot stops at

random: crng init done

, I’m supposed to press Enter right? But the keyboard is not working, tried two but no use. Although I plugged a mouse and it worked!

What should I do ?


At boot, the kernel waits for mouse movements to initialize the random number generator.

Not sure if it helps but maybe you can try to following

apt-get install haveged
systemctl enable haveged

On our RPi image, rng-tools is installed, which should render haveged obsolete.

For first boot, attach some mouse or keyboard and move/type, or wait for a few minutes until the system gathered entropy from elsewhere.

Then check if rng-tools is running:

systemctl status rngd
journalctl -u rngd

Joulinar, I can’t type anything, the whole keyboard is not working. I tried moving and clicking the mouse but nothing happened (though it’s working)

As I mentioned previously, I can’t type anything since the whole keyboard is not working with the os (though it worked with raspbian before). And the mouse moving/clicking did nothing.
I just noticed I’m having [end kernel panic] and an error loading libraries:


did you tried a fresh installation on a different SD Card?

No, does that mean the image is corrupted ? I’ll try another SD

you never know. It could be SD card, the download image or something went wrong during flashing. Just to ensure that this is not the case.

Okay the kernel panic is a good reason why things hang. Yes please try to reflash.