Kernel modules fail to load after update to 8.22.3

  • DietPi version

  • Distro version

  • Kernel version
    Linux mbp2012-dietpi 6.1.0-12-amd64 #1 SMP PREEMPT_DYNAMIC Debian 6.1.52-1 (2023-09-07) x86_64 GNU/Linux

  • Architecture

  • SBC model
    Native PC (x86_64)

  • Power supply used
    Mac Mini

  • SD card used

Actual behaviour

on boot, kernel modules fail to load. I have installed tailscale, which subsequently also fails (this is how I detected the issue, as tailscale will not run). I have tried to reinstall and re-update, but no change

…wondering if I can downgrade to check operations. any reference for downgrading?

following diagnostic instructions here:

I found that an /etc/modules-load.d/nvidia.conf file with “nvidia-drm” listed, which was somehow offensive. never has been before that I know of, but this might be a new option. commenting that line eliminated the issue for systemd-modules-load, which now completes successfully.

however, this has not fixed my tailscale issue. following a similar procedure for tailscaled I find this error…

mbp2012-dietpi tailscaled[3066]: wgengine.NewUserspaceEngine(tun “tailscale0”) error: creating router: exec: “iptables”: executable file not found in $PATH

i do not have (and did not have) iptables installed. does tailscale now have a new dependency on iptables?

manuall installing iptables fixes the problem. seems like a dependency that should maybe be resolved by the tailscale install?

1 Like

well done, you analyzed the issue perfectly. It seems iptables is a hard dependency nowadays, however it’s listed as recommended package only.

[ INFO ] DietPi-Software | APT install tailscale, please wait...
Reading package lists...
Building dependency tree...
Reading state information...
Recommended packages:
  tailscale-archive-keyring iptables
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.

This would be a task for Tailscale’s Debian package maintainer to correct in his apt package. Theoretically we could build workarounds and install iptables manually, but the better solution is to provide the correct apt packages directly from the Tailscale side.

BTW: same behavior on Debian Bullseye.

1 Like

WRT the Nvidia issue…

not sure why I would be including Nvidia drivers anyway, since I think my intel Macs have intel video. just let the default stand, I guess. I have now updated (via dietpi-config) to select the intel drivers and all is well (that is, the kernel modules load without fail). I run the LXQt desktop, but never on the local machine…always via screen sharing (VNC), so I don’t know if the selection of GPU driver makes any difference at all.

Had the same issue with it not loading. Applied the manual fix of installing iptables. Thank you for the comment with the fix!

we got feedback from Tailscale. Tailscale requires iptables but they aren't installed · Issue #6649 · MichaIng/DietPi · GitHub

Actually this is working as desinged and we will adjust our install script on next release.

New message from Tailscale side

FYI, we had a discussion internally and will return a strict dependency on iptables. In the future when Tailscale client can auto-detect and use nftables, either of the two will be sufficient as a dependency.

1 Like

quite interesting. never expected to drive behavior on either your team or tailscale’s…

we take user feedback seriously and try to create a good user experience :wink:

1 Like

I read above and the github troubleshooting but don’t understand the resolution, what does this mean for us less-technical DietPi users? Is it something an upcoming tailscale update will fix? Or an upcoming DietPi update will fix? Or tailscale will continue to need manual iptables (and how)?

thank you!!

Until Tailscale added back dependency on iptables package, it would need to be installed manually.

ah, I didn’t realize at first it’s as simple as running ‘sudo apt-get install iptables’

all working now! thanks!