JustBoom Digi Zero and MPD config (/etc/mpd.conf)

JustBoom on their website advises to set output setting in /etc/mpd.cong as follows:

audio_output {
type “alsa”
name “JustBoom”
device “hw:0,0”
mixer_type “software”
mixer_device “digital”

, which macthes my setup (externdal DAC) better than the parameters dietpi-justboom helper configures:

The helper sets sample rate and bit depth, which forces re-sampling if the sample rate of input does not match the set parameters. As my DAC can handle different input formats re-sampling is not required for the formats in my music collection.

Would be great if the helper can include the Justboom endorsed setup which leaves out the “format” variable and sets mixer_device.

Thanks, Maarten

PS DietPi Rocks !!!

Reasonable suggestion. I will move this topic to “Requests”, where it fits better?

Thx !

Pity my request is not taken into account with v6.20.5…

DietPi-Justboom config menu still forces frquency and bitdepth to be set. Forcing MPD to resample when input has different frequency and/or bitdepth…

Sorry, simply too much requests to handle to remember and implement everything. I now link it to GitHub, where it’s closer to development and our eyes: https://github.com/Fourdee/DietPi/issues/2461

This has been implemented with v7.7: https://github.com/MichaIng/DietPi/commit/9d6197fbd2aa04a8ce5ace57ca27305476558e00
Actually initially I intended to only bugfix false format detection since we by default do not overwrite it in mpd.conf anymore (so the settings are not present), but it was only reasonably to additionally allow them to stay unset.