Jellyfin - No audio when playing from another device

I’m at a loss as to how to resolve this.
I have Jellyfin installed on a Pi4b and I can play files directly from it using NoMachine back to the Pi box with sound coming from the attached speakers. I have a justboom DAC attached.
When I access using http on my desktop pc, everything appears normal, the music shows as playing but there is no sound from the speakers attached to the Pi.
Volume controls on my pc show output from firefox.
Can anyone help on this?

Jellyfin a streaming app, so the sound is coming from your client machine (your PC), which is fine.
But you want to remote controle your Pi, right? You want to access the Pi from another machine but the sound should come from the Pi speakers?!
You could use a VNC to achieve that.

Sorry for the delay.
Sound via VNC works. No sound if accessing from another PC using a browser.
I then tried with LMS and got sound both via VNC and from browser on another pc.
So it seems to be a Jellyfin issue.
I’ll investigate further but I’m running out of ideas.

I finally worked this out.
LMS has a DLNA plugin that allows playback through the DAC using the Squeezelite App.
In Dietpi software there is a UPNP/DLNA application called gmediarender. I installed and can now Chromecast using Jellyfin on any pc or mobile device.

1 Like