Is there a way to change architecture?

Hi there!

I have noticed that my Dietpi OS architecture is armhf in a rpi4. I wonder how to migrate the user data a fresh installation? Does dietpi-back help in that purpose? Is it ok to copy paste the user data folder (I want to keep the configurations)?

Should I install this DietPi_RPi-ARMv8-Bookworm.img.xz?

Is there a way to migrate the containers’ configurations that I have?

Thank you in advance.

you can easily migrate docker containers between distro’s

I used this method the other day and it worked great

What SBC are you putting ARMv8 on?

Proper way to upgrade to a different architecture is to move/migrate data…then re-image/flash new SD…I think there is a way to use apt and other methods…but it can cause errors/issues with scripting and file names/locations

No, this will not work, because our backup is a full system backup including everything.

Depends on your apps installed. For some it might work, for some not.

depends on where you have stored container config files. Container itself you can’t migrate because they depend on architecture.

Thank you for the guide.

My SBC is a Rpi 4 4gb.

Thank you.

Should I install this DietPi_RPi-ARMv8-Bookworm.img.xz?

yes, this would be the 64bit image for Raspberry Pi device.

One question, why do you like to switch from 32bit to 64bit. Any strict need? Or just because you like to?

Some of the containers I use are deprecated and there aren’t any armlh updates. So I think it’s goog to migrate. What are your 2c on that?

Before starting a migration, have a look to your containers and if they are available an ARMv8 / 64bit.

Double checked it.

Thank you for your help.

believe it or not…there are ALOT of ARMv7 built docker images over at dockerhub, just click the arm and check the flags for that version

I guess OP was looking for specific images, not offering ARMv7 anymore. Therefore he need/like to switch to ARMv8

1 Like

Thank you for your answers and help.

The migration was easier than expected. Everything is up and running again.

  1. The -rr tools have their own backup system and it worked perfectly.

  2. I copied some config files from dietpi_userdata for the containers.

  3. Same thing worked for Jellyfin.

1 Like