Internet out for 2 mins, RPi drops off local network and stays off

to be clear, it (appears to) boot up perfectly when the HDMI and keyboard are not plugged in. I can’t tell for sure, but I can SSH in OK and docker is up and running home assistant etc etc.

It’s a Kingston SSD and the Pi is powered by the official Argon One power supply as it is in an Argon ONE case.

Good news though, I remembered I had a Deco P9 connected to the router (my mesh WIFI) with a spare port so I have plugged my Pi into that and not into the router. …it just survived a router restart! I’m doing anther one just to be sure, hang on…

Edit: Yep, that’s 2 router restarts that it has survived now.

…when I was setting it up, I had the HDMI plugged directly into the Pi (It’s wasn’t in it’s Argon ONE case then). Now that it is in the case, I am plugged into the Argon ONE’s HDMI port (which in turn is connected to the Pi). …could The Argon One case itself be a problem?

Edit: Forgot to add, the SSD is powered by the Pi. I have had the same setup (different case) with my Pi for years with no issues.

Edit: I brought a spare Pi with me (in the exact same case that my ‘good’ Pi is in). I shutdown the bad Pi, transferred the Sonoff stick, SDD and
network cable to the new Pi and started up with the HDMI and keyboard attached (that didn’t work on the ‘bad’ Pi).


No drive errors, logged in OK and ip a shown. I am now going to reconnect directly to the router and restart. Will let you know…

OK, so it did not survive a restart whilst directly connected to the router, but I did get an ip a this time (the 1st was before the restart, the 2nd after). …it looks like the PI has kept it’s IP, but maybe not too surprising as it is static?


  • ‘bad pi’ will survive a router restart when connected via my Deco P9
  • my spare Pi had the same results as the ‘bad Pi’ re: restarts
  • the Argon ONE was preventing me using the HDMI and keyboard
  • my SSD is OK

…apologies for the horrendous typos - now fixed.

Maybe the Argon enclosure is not able to supply enough power to fully use HDMI? Sorry to be so stupid, but I have no experience with Argon devices :rofl:

A few thoughts that don’t have to be right either: Maybe RPi SBC has a problem with the recognition of the Ethernet status when the link is briefly gone (router restart). Therefore, it works with the small switch in between. Here the Ethernet link remains all the time.

I have never used an Argon ONE before and have no knowledge, but it seems weird to me that they supply their own (full size) HDMI ports but their own power supply isn’t enough for it. I’m getting a 3rd one of my existing cases as I have experience with them.

One of my 3 PI’s works and 2 don’t, so that is also weird. I now have the bad Pi, and mum has my backup Pi - which exhibits the same behaviour of course - so I can play with her Pi over the next few days. I am keen to power it and restart my router (we both have the same make/model, but I want to prove it out as well).

When I restart the router, it is offline (internet) for over 2 mins. I am not sure how long it is offline (LAN) for though.

Other than that, do you have any suggestions to get to the bottom of this? The difference in settings I wrote out above wont make any difference (I don’t know what they do)?

does all of them have the same hardware revision? and they are all running some kernel and Debian version?

Here you go:

Unit DiePi Kernel Hardware
‘Good’ Pi v8.20.1 Linux 6.1.21-v8+ aarch64 BCM2835, Rev: b03114 - Model: 4B, Rev 1.4
‘Bad’ Pi v8.20.1 Linux 6.1.21-v8+ aarch64 BCM2835, Rev: b03115 - Model: 4B, Rev 1.5
‘Bad’ Pi 2 n/a Linux 6.1.21-v8+ aarch64 BCM2835, Rev: b03115 - Model: 4B, Rev 1.5

…so the ‘good’ Pi has a different hardware revision.

any thoughts?

I would say, there’s something wrong with the Revision 1.5, altough I couldn’t find similiar cases.
Maybe someone can test with their RPi 4 Rev 1.5, mine is 1.3 I guess, I have to look when I’m home.

Well, I have already tested with 2x v1.5 and a v1.4. Both v1.5 failed and the 1.4 was OK.

The v1.5s are the first after the supply problem so I would expect more people to see this issue shortly (if it is a v1.5 problem).

maybe it’s a challenge with onboard Ethernet controller not being able to deal with short interrupts.

@jchh would you are able to test with plain RPi OS? Same kernel aso?

Just to clarify, the two RPis are sitting in different networks, so we can assume the network/router being the key difference, not any setting/SPI/I2C being toggled on them, right?

On the Pi with the problem, does this help to mitigate the issue?

sudo ethtool --set-eee eth0 eee off

This (temporarily) disables the Energy Energy Ethernet mode, which seems to cause issues at least with some routers/switches which do not (fully) support the EEE implementation of the RPi: Add option to disable EEE on the Pi 4 eth0 interface · Issue #6577 · MichaIng/DietPi · GitHub

It makes perfectly sense that EEE kicks in when the carrier signal is lost (on router reboot), and probably its these few routers which do not manage to wake up the RPi Ethernet adapter again, so that network connectivity stays off.

I’ll try this tomorrow.

I have 3 RPIs and 2 separate networks (different locations), but both using the same router model with the same provider. I tried both ‘bad’ RPIs on the remote network, but one of them is with me now with the good RPI on my home network so I can try it again tomorrow to prove out the network differences (or not).

I’ll try this tomorrow as well.

Thanks, both!

Is there a watchdog script that can try to ping something online, if it fails a few times, then issue a network down then up again?

Here is a pretty in depth script from github where you can set options to either reboot or just restart networking

I am running uptime_kuma which lets me know when it has reconnected after a disconnection. The problem with this particular issue is that it never reconnects - only a full reset address the problem.

I’ll try those things from @Joulinar and @MichaIng over the weekend.

1 Like