Installing Sumologic collector in Dietpi


I have a project which home-cloud security. I decided to do this project with raspberry pi, so I installed diet pi in it, and eventually, I installed nextcloud as my cloud. I finished all the configurations, and now I am about to attack it to check the security. However, to do so, I need to monitor the attack with Sumologic. Anyways, I tried to install the Sumologic agent many times in many ways, but it seems that diet pi is not accepting the agent. the first error I have is:

./ 240: bin/unpack200: Exec format error
Error unpacking jar files. The architecture or bitness (32/64)
of the bundled JVM might not match your machine.

Where is my sumologic collector.

Is it something missing in dietpi?

Welcome to the community.

Are you sure the architecture of your application is fitting to the architecture of your image? Maybe you need to check if you require ARMv7 32bit or ARMv8 64bit

no actually Im not
just following the instructions I got from SumoLogic support:

if not how to do so?

what type of image did you installed?

the latest one:

Linux DietPi 5.15.32-v7l+ #1538 SMP Thu Mar 31 19:39:41 BST 2022 armv7l GNU/Linux

And what is the URL of the collector you download?

I tried all of them… Linux one, and Debian as dietpi is based on Debian, and RPM
I tried tarball today … none of them is working

It would be helpful if you could share the link to the Debian package you tried.

They are all 64bit files where you installed 32bit os. Of course this doesn’t fit. If you like to use 64bit, you would need to use our ARMv8 image.

As well you need packages for ARM architecture and not AMD. I guess that’s where you need to use these wrapper script that is described on your first link. Best to contact sumologic support, If there are questions on the usage.

Thank you … i will try that

It is working fine now. I started all over again with 64 image and manually configured the sumo logic agent. Thanks again