Installing DietPie on Rock64 and set 1280x1024 resolution

Thanks in advance for taking the time of reading this and possibly trying to help.

I recently got a 1 GB ROCK64, and I want to install DietPi on it. I have a 32 GB Class 10 micro SD card, a Realtek RTL8188EU Wi-FI USB dongle and a wireless keyboard + mouse combo, so up to this point I assume I’m properly equipped for the installation. The thing is I don’t have any 1080p TVs or monitors (I live in Venezuela), but I do have an HDMI to VGA converter, which I’m planning to use with a 1280x1024 monitor.

I already tried flashing the image to the micro SD card using Etcher, and the ROCK64 seems to boot up but no image appears on screen. I presume that it is booting up because the mouse turns on when I power the ROCK64.

Although I’m a Linux user, I’m completely new to the SBC world. Please, do keep that in mind.

I want to know how to change the resolution so I can proceed with the installation. I already tried Googling this issue, and even though there is comprehensive information on the subject, I couldn’t find a specific solution for the ROCK64. I don’t know which file I have to edit to change the resolution of the output.

I presume the issue is exclusively the output resolution, but I can’t be sure. I hope someone more experienced can tell me what possibly could be wrong.

I have to add that all 3 lights of the board turn on and stay like that. I haven’t tried leaving the board on for a while.


I just bought a couple Rock64-v2 boards to experiment with and just saw your post. I tried loading different images directly to the SD card, e.g. ubuntu, manjaro, dietpi, and while the images seemed to load correctly on the SD (using etcher and win32diskImager) the Rock64 had problems booting up. Either it didn’t boot, the HDMI interface didn’t work, etc. I went to (the Rock64 site) and installed their pine64 installer program (v2.0.0-beta.3 on Windows 10) and used that to load the SD card. It has a menu list of available distributions for the Rock64. In this case I loaded the DietPi Community Build (ROCK64 microSD/eMMC) build v6.20 image on a 16GB Sandisk Ultra (red) Card and it came right up fully functional. Hope this helps.