Installing DietPi (VirtualBox Image) on Synology VMM

Hi all,

I’m trying to install DietPi (Bookworm) image on a Synology NAS (v7.1.1 - using VMM). I’m using the VirtualBox image and did a standard OVA import (after extracting the image with 7zip). The VM however won’t boot.

It looks like I get as far as formatting the disk… It lists “old situation” /dev/sda1 and has start and ending values for disk formatting. And then lists “new situation” and is completely blank and doesn’t get any further in the boot process.

Has anyone seen this before?


I also tried this with an ISO UEFI image and install from scratch. I get roughly to the same spot… Old situation, new situation then it just hangs as “partition table has been altered.”

I’m running a couple of VM’s on my Synology DS216+II (DSM 7.2.1-69057, VMM 2.6.5-12202)

Just created a new test VM using the VBox Bookworm ova image

 DietPi v8.22.3 : 07:49 - Wed 09/27/23
 - Device model : Virtual Machine (x86_64)
 - LAN IP : (eth0)
 - Freespace (RootFS) : 8.7G
 - MOTD : DietPi v8.22 is here. Check out all changes:


 DietPi Team     :
 Patreon Legends : Chris Gelatt,
 Website         : |
 Contribute      :
 Web Hosting by  :

 dietpi-launcher : All the DietPi programs in one place
 dietpi-config   : Feature rich configuration tool for your device
 dietpi-software : Select optimised software for installation
 htop            : Resource monitor
 cpu             : Shows CPU information and stats


Everything was hanging until I changed the display driver to “vga” from “vmvga”. Changing to “vga” fixed all the console freezes.

ahh you tried to connect via the local console? Because the SSH login should work regardless of the display driver settings.