Installing DietPi on Thin Client (Pi Alternative) fails

Hi at all,

I got a used Fujitsu S920 Thin client (AMD G-Serie GX-222GC CPU) and tried to install DietPi natively using my USB Image (UEFI). Installer works fine, installs some partitions and then goes black. “No proper boot device found” when I try to start again and even manually selecting the internal 8GB SSD as boot drive.
Could it be the USB drive is incompatible or should I use legacy-Image just in case? I noticed the BIOS Version to be way bigger than UEFI. And the file extensions are different (UEFI=.iso, BIOS=.img).

Best wishes.

P.S.: Here is the data sheet for the thin client:

There should be 2 different version available for the BIOS version.

  1. Direct write Image
  2. Installer Image

The installer can be used to boot from a USB stick and write DietPi to an internal drive. While the direct write image should be flashed to a drive directly.

Installer images are around 600MB while the direct write image is around 200MB

1 Like

Worked like a charm with the right image. Installed and happy with my 20 bucks machine and 7,4 W in idle. Will do the job until Pi 4 is down to normal prices again.

1 Like