Installing COPS server

I’ve installed Syncthing and Ubooquity on my DietPi + Pi2. Using Syncthing to copy the Calibre e-book library from my PC to a flash drive attached to the Pi2. With the view to accessing the Ubooquity library web interface via my Kobo e-reader’s built in web-browser.

Unfortunately, while I can open the Ubooquity library on my PC and smartphone with ease, the e-reader can’t cope. An attempt to open the Books section delivers a 404 Not Found. The Latest Books section will sometimes open and sometimes not. Any success can take 30-45 seconds.

Maybe it’s the size of the library that causes the problem, or maybe it’s a Java thing. Either way, I’d like to remove Ubooquity and replace it with the lightweight COPS server. Not only is COPS a far better choice for handling a Calibre library, but it also worked seamlessly with my e-reader when installed on my (sadly now broken) NAS. The server installed as an add-on package via the NAS GUI. I wouldn’t have had the technical chops to install it any other way.

If it’s not too cheeky or too much of a bother, please could someone take a quick look at this guide for installing COPS on a Raspberry Pi with Raspbian Buster? I’m hoping that I could just paste the code in to a terminal and everything will just slot in to place with DietPi. Just changing one or two things like the location of my library. However, the chance of it being that simple are slim and I’m sure to get something wrong: overlooking an obvious conflict or missing element.

Any thoughts and guidance much appreciated.



in theory this might be possible. You just need to adjust the user/home directory as well as ip configurations.

It worked! And it’s instantly accessible from my Kobo e-reader. So much better than Ubooquity. Thanks for the hand-holding reassurance.