Installation problem on OrangePi PC [SOLVED]

Hello,
I am having problems with the installation of DietPi on my OrangePi PC.
I have dowloaded the image and then installed it on my microsd card with the command (I am using Linux Mint 18 64-bit version):

sudo dd if=/home/myuser/OrangePi/DietPi/DietPi_v127_OrangePiPC-armv7.img of=/dev/mmcblk0

The image is burned correctly on the card, as the two partitions are created correctly, but when I insert the card in the OPiPC nothing happens.
The green led is on, and both the ethernet leds are on, but that’s it.

It’s not a problem with the card, because it’s the exact same card I used with loboris image of Ubuntu Mate and it has worked perfectly until five minutes ago :slight_smile:

Any suggestions?
Thanks

You will find a lot of lament and approaches here:
http://www.cnx-software.com/2015/10/02/orange-pi-pc-not-booting-you-are-not-alone/
I can confirm, that OPi PC works well with DietPi.
Nevertheless, it took me a while to realize, that the OTG-USB is not a power plug for my raspberry power-supply…

Frans

The fact is that my OPi PC is not a new board. I have been using it successfully for a year with Ubuntu Mate and if I switch cards it boots normally, using the same (official) power supply (therefore the hardware works)
There must be something wrong with the DietPi image (not with the image itself, since it works for other people, but maybe with the procedure I’m using to create the card, I don’t know…)

There’s nothing wrong with your dd command. (If you mount the source-image prior cloning, the output may be corrupt).
As far as I know, the red onboard led is on, when there is a valid boot-image found, otherwise there’s something wrong with card or partitions.
Are you able to mount both SD partitions from your Linux Mint and there’s some boot and userspace content available?
If it looks fine, I’d retry it with another SD, no better idea from here, sorry.

I am not mounting the source image before writing it on the card.

Here is the content of the Linux Mint card (each panel shows one of the two partitions):


And here is the content of the DietPi card:

I’m puzzled. :thinking:

OK, this is a mystery but…
I have just tried again with the same 32Gb card I tried with (twice) yesterday.
After putting the card in the OPi, same green led (instead of the red one that I’m used to get when using loboris’s image of Ubuntu Mate) BUT… after a short time I noticed that the router’s led correspondent to the port to which the OPi is attached turned on…
I tried connecting via SSH to the OPi and it now works!
I have no idea what went wrong yesterday: same sd card, same command, same image…
Well, all’s well what ends well. :smiley:

When I mount the dietpi-Opi-image, I end up with two mounted partitions.
One is “BOOT” and one is a device-id that contains the system.
Mine looks different from yours?
You should end up with these two partitions when mounting your SD-card too.

Thanks, mine looks (and looked) exactly like yours.
Anyway, you might have missed my previous post (as we have posted almost at the same time): now it magically works, even though I have done nothing different than what I did yesterday. :open_mouth:

Now on with the testing of LMS/Squeezelite on the OPi PC! :slight_smile:

Thanks a lot for your help, though!