Installation on OEM2550L2D-MX

Either i’m losing my mind or this is simply not compatible.

Link to PC in question: http://www.oemproduction.com/products/2700L2D-MxPC.asp

Its running an ATOM D2550 Processor - 8GB RAM - 2 HDD’s
Hard drives are a 16GB SSD (I’m trying to install to) and a 700 GB spinning metal drive.

This claims to have a UEFI bios so I’ve been using DietPi_NativePC-UEFI-x86_64-Buster.iso, and flashing to a usb flash drive. Flashing drive with Rufus and changing partition scheme to GPT per the instructions.

I can get as far as dietpi install screen. Though I do get an error that it can’t read the .bmp file for the background (Unsupported Format).

After selecting any option I get just a plain blue screen for several seconds then the display goes black and that’s it.

I’ve tried using an old dell and installing directly to the drive, then transferring to this computer but I get a Insert proper boot device and reboot message.

I should add that I had OpenMeiaVault installed on this pc. It booted and installed no problem.

Any help would be appreciated.

Hi,

many thanks for your message. Maybe you can have a look to the following guide if the image themselves is not working. It will describe hot wo setup a Debian mini image and install DietPi on top

https://github.com/MichaIng/DietPi/wiki/How-to-create-a-DietPi-image-for-x86_64-PCs-(UEFI)

Thanks, i’ll give this a try.

Sorry it took so long but that worked!

I have dietpi loaded but I’m getting a DNS resolver error on login. I can’t ping 9.9.9.9 no matter what I try. Even on a different PC on my network.

I’ve changed the wait time and I’ve tried changing the IP address to 8.8.8.8 (if that even matters), and nothing.

At the terminal I can ping 8.8.8.8 fine though.

I’ve also tried using my router as DNS and a few of the other options in the list. What am I missing?

In the etc/network/interfaces it looks like this:

root@DietPi:~# cat /etc/network/interfaces
# Location: /etc/network/interfaces
# Please modify network settings via: dietpi-config
# Or create your own drop-ins in: /etc/network/interfaces.d/

# Drop-in configs
source interfaces.d/*

# Local
auto lo
iface lo inet loopback

# Ethernet
allow-hotplug eth0
iface eth0 inet static
address 192.168.1.9
netmask 255.255.255.0
gateway 192.168.1.1
#dns-nameservers 8.8.8.8 8.8.4.4

# WiFi
#allow-hotplug wlan0
iface wlan0 inet dhcp
address 0.0.0.0
netmask 0.0.0.0
gateway 0.0.0.0
#dns-nameservers 0.0.0.0
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Should dns-nameservers have “#” in front of it?

Are you able to ping anything on the web from your DietPi system?

Yes I can.

did you already adjusted the connectivity check? If not do nano /DietPi/dietpi.txt and search for the following 2 lines:

# General connection and DNS testing
# - IP to ping when checking network connectivity. Default: 1.1.1.1 (Cloudflare DNS, should be very fast world-wide)
CONFIG_CHECK_CONNECTION_IP=1.1.1.1
# - Domain to ping when checking DNS resolver. Default: one.one.one.one (Cloudflare DNS domain, see above)
CONFIG_CHECK_DNS_DOMAIN=one.one.one.one

It can be changed to something you are able to reach

Thanks!! I’m in now. Thanks for all of your help!!

just out of interest. What connectivity check configuration do you use now?

IP Address 8.8.8.8
Domain to ping: google.com

if you don’t like Google, you could check Quad9 as alternative 9.9.9.9 and dns9.quad9.net