Installation of Raspotify fails


I removed raspotify because it stopped working and now I’m trying to install it again using dietpi-software.
This results in the following error.

[  OK  ] DietPi-Software | APT update
[ INFO ] DietPi-Software | APT install for: raspotify, please wait...
E: Unable to correct problems, you have held broken packages.
[FAILED] DietPi-Software | APT install for: raspotify
 - Command: apt-get -qq --allow-change-held-packages install raspotify

- DietPi has encountered an error                                   -
- Please create a ticket: -
- Copy and paste only the BLUE lines below into the ticket          -
#### Details:
- Date           | Thu Feb  3 22:35:09 CET 2022
- DietPi version | v8.0.2 (MichaIng/master)
- Image creator  | DietPi Core Team
- Pre-image      | Raspberry Pi OS Lite
- Hardware       | RPi CM 3+ (armv7l) (ID=3)
- Kernel version | `Linux DietPi-USBridge 5.10.63-v7+ #1496 SMP Wed Dec 1 15:58:11 GMT 2021 armv7l GNU/Linux`
- Distro         | buster (ID=5,RASPBIAN=1)
- Command        | `apt-get -qq --allow-change-held-packages install raspotify`
- Exit code      | 100
- Software title | DietPi-Software

I also tried to install raspotify manually, but this also fails.

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 raspotify : Depends: libasound2 (>= 1.2.4)
             Depends: systemd (>= 247.3) but 241-7~deb10u8+rpi1 is to be installed
             Depends: init-system-helpers (>= 1.60) but 1.56+nmu1 is to be installed
E: Unable to correct problems, you have held broken packages.

Any help would be much appreciated!


your issue is the Debian version Buster you are running. Because there is a package depending on init-system-helpers >= 1.60. However your system is trying to install 1.56+nmu1, which is the last one on Buster. Similar with systemd package.

Looks like Raspotify require Bullseye now
There is as well a issue on Raspotify GitHub confirming it

On our next release 8.1, it will be disabled on Buster now.

If you like, you could upgrade following our blog

That’s sad, because I put quite a lot of work into settings things up.
I’ll look into your recommendation to update to Bullseye.


it was a decision done by Raspotify developer. Nothing we could influence. sadly.

Keep in mind to do a backup on your system, before going the upgrade path.

But the good side is that it is supported on ARMv8 and x86_64 platforms now :slight_smile:. For Buster, Spotifyd should be a neat solution, or Spotify Connect Web when a web interface is wanted.

It took me a few hours to upgrade, but everything is working great. Nice and clean install :slight_smile:

Fyi. I’m using DietPi in combination with an Allo USBridge with just squeezelite, raspotify and tidal connect (Docker) installed. I love the simplicity of DietPi!

Great, many thanks for the feedback :slight_smile:.