Install DietPi as second OS with script usage failed

Ich schreibe hier in Deutsch. OK?

ADMIN edit: translated into English using

Initial scenario: Windows 11 Home is running on PC.
The “clean install” does not work here. Existing partitions must be retained.
So: Read the article: Install dietpi on a PC alongside windows…

Debian 12 NetInst on USB, then installed.
I do NOT have Ethernet available.
WiFi connection established. Script loaded and run.

Script gets stuck at one point. After restarting the PC, I ran the script again. WiFi still worked. Then the script ran through without getting stuck. Yay!!!

So next notbook, same procedure. Stuck in the script again. Restart with script. No success.

Too long for me now. Question: Write the now working installation to USB ( Gparted, Partclone, DD ?). Then what to do? What changes have to be made before the first boot so that DietPi also runs on the 2nd computer.

I hope someone has a solution for my problem.
Thank you very much.


Pls stick to English language. We are an international community and there are quite some online translation tools available like DeepL

You need to share some error messages and more details on your issue. What you see on screen. What happen exactly?

This will not work to clone desktop partition to your laptop.

I do not remeber exactly where the install script sticks. But I will give it a new trial of installing Dietpi as second OS on an UEFI Notebook. But this time I will use an Ethernet Connection instead of WiFi. Maybe the script needs Ethernet and “ignores” WiFi at some point.
I give an update of success or failure.
Thanks for the answers.

Back with new results:

I removed the debian 12/dietpi-partition. Then I installed Debian 12 Netinst on this partition with Mate-Desktop. Ethernet was connected during Debian installation. Reboot. Find dietpi-install-script with google.
Followed the installation guide.
Selected Master-Bookworm
Selected need wifi.
then started script.
Script ran and finished with no errors.
After reboot ran dietpi-config. System is now running.

Seems that running the installation script without ethernet causes errors.
Maybe this helps someone.