Influxdb is not starting after dietpi-update or installation of other software

Creating a bug report/issue

Required Information


  • Distro version | bullseye 1

  • Kernel version | Linux ZeroW 6.1.21+ #1642 Mon Apr 3 17:19:14 BST 2023 armv6l GNU/Linux

  • Architecture | armhf

  • SBC model | RPi Zero W (armv6l) or (EG: RPi3)

  • Power supply used | Standart USB-Power supply

  • SD card used | Sandisk

Additional Information (if applicable)

  • Software title | influxDB
  • Was the software title installed freshly or updated/migrated?
    was installed and running finde
  • Can this issue be replicated on a fresh installation of DietPi?

The installation was almost fresh.

← If you sent a “dietpi-bugreport”, please paste the ID here →

  • Bug report ID | 23a02083-5ec7-4a55-8666-942ee2a4ede7

Steps to reproduce

Fresh installation of version 8.16.x a few days ago with fhem, influxdb and grafana (last two via dietpi-software). All was good and running fine. Yesterday I did the dietpi-update to 8.17.2. During this dietpi stopped a few services incl. influxdb. After the update dietpi tried to start influxdb again but after a while I got [FAILED] DietPi-Services | restart : influxdb and if I check the server I see the following:

root@ZeroW:~# systemctl status influxd
● influxdb.service - InfluxDB is an open-source, distributed, time series database
     Loaded: loaded (/lib/systemd/system/influxdb.service; enabled; vendor preset: enabled)
     Active: activating (start) since Wed 2023-05-17 14:30:47 CEST; 1min 7s ago
Cntrl PID: 10056 (influxd-systemd)
      Tasks: 9 (limit: 990)
     Memory: 103.9M
        CPU: 46.331s
     CGroup: /system.slice/influxdb.service
             ├─10056 /bin/bash -e /usr/lib/influxdb/scripts/
             ├─10057 /usr/bin/influxd -config /etc/influxdb/influxdb.conf
             └─10229 sleep 1

Mai 17 14:31:42 ZeroW[10056]: InfluxDB API unavailable after 36 attempts...
Mai 17 14:31:43 ZeroW[10056]: InfluxDB API unavailable after 37 attempts...
Mai 17 14:31:44 ZeroW[10056]: InfluxDB API unavailable after 38 attempts...
Mai 17 14:31:46 ZeroW[10056]: InfluxDB API unavailable after 39 attempts...
Mai 17 14:31:47 ZeroW[10056]: InfluxDB API unavailable after 40 attempts...
Mai 17 14:31:48 ZeroW[10056]: InfluxDB API unavailable after 41 attempts...
Mai 17 14:31:50 ZeroW[10056]: InfluxDB API unavailable after 42 attempts...
Mai 17 14:31:51 ZeroW[10056]: InfluxDB API unavailable after 43 attempts...
Mai 17 14:31:52 ZeroW[10056]: InfluxDB API unavailable after 44 attempts...
Mai 17 14:31:54 ZeroW[10056]: InfluxDB API unavailable after 45 attempts...

I add the journalctl -xe output as a file. To get that fast resolved I de-installed and installed influxdb and all was good. Today I run dietpi-software to install nfs-client with the same result. Stopping influxdb during the installation process but not starting again after. A reboot of dietpi also did not restarted influxdb.

Expected behaviour

Stopping and starting influxdb without any issue.

Actual behaviour

After stopping influxdb it’s not starting again fine.
journalctl.txt (155.7 KB)

ok looks like InfluxDB requires some time to start correctly. Especially on such a small device like RPi Zero W. Did you watch memory + CPU consumption on your SBC? using htop?

Another idea would be to extend timeout value InfluxDB API unavailable after X attempts... · Issue #23639 · influxdata/influxdb · GitHub

Hi @Joulinar,

in the meantime I used google and found

With that I changed the 3 lines in my influxd.service and restarted influxdb-service successfull. After a few seconds it’s working again fine. When I do a htop now, influxdb is using up to 73-93 % CPU but not the whole time. The system himself has a load avarage of 0.41.

Next step is to change the influxd.service file back to original and adapt the timeout value you mentioned.