Increase partition size

Hi at all,

I use DietPi in VirtualBox and just increased the Virtual Disk from 8GB to 16GB. Then I selected “dietpi-drive_manager” to increase the RootFS partition to the new maximum. Unfortunately is still is as small as before.

What am I missing here?

Best wishes!

Just checked on a demo VirtBox VM without issues. Can you check following

lsblk -o name,fstype,label,size,ro,type,mountpoint,partuuid,uuid
fdisk -l

do you have a graphical desktop installed?
If so install gparted and resize that way, just tell it to expand the main partition to use the entirety of the new “virtual” partition…otherwise you will have to use command line

1 Like

that is what I have right now:


I even increased all the other virtual drives I have for othre VMs to 16GB. I think it has to do woith snapshots somehow.

Did some poking around in the forum

Per MichaIng

systemctl enable dietpi-fs_partition_resize
reboot
1 Like

thanks for your help. I managed to fix it by exporting the “appliances” (VMs) to an .ova file. that forced the snapshots to be merged. then I re-imported them and deleted everything else that was not needed anymore. Now I could resize without a problem.

good you found it.

You seem to have increased the size of virtual drive for an older snapshot, while the current one was still 8 GB. Take care to select the latest snapshot when using the resize slider in VBox.

I Just tried the Same procedure on another VM. And this time it Just wont increase. This ckmes Up af start

Any Help would bei great.

yap, know issue that should be fixed on next release. For testing, I initiated a dev build for a VBox image DietPi-Build · MichaIng/DietPi@e42e420 · GitHub

1 Like

Will wait then. Thanks.

dev vBox image should be there already. Index of /downloads/images/testing

2 Likes

But I would have to start from Scratch then. I will wait for a on the fly fix.

sudo sed -i 's/MOUNTPOINTS/MOUNTPOINT/' /var/lib/dietpi/services/fs_partition_resize.sh
sudo /var/lib/dietpi/services/fs_partition_resize.sh
1 Like

worked like a charm. thanks so much!!!

1 Like